aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 11 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7cf9236..8b8853a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,17 +3,16 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "bindgen"
-version = "0.58.1"
+version = "0.59.2"
authors = ["Jyun-Yan You <jyyou.tw@gmail.com>", "Emilio Cobos Álvarez <emilio@crisal.io>", "Nick Fitzgerald <fitzgen@gmail.com>", "The Servo project developers"]
build = "build.rs"
include = ["LICENSE", "README.md", "Cargo.toml", "build.rs", "src/*.rs", "src/**/*.rs"]
@@ -38,7 +37,7 @@ required-features = ["clap"]
version = "1.0.3"
[dependencies.cexpr]
-version = "0.4"
+version = "0.6"
[dependencies.clang-sys]
version = "1"
@@ -49,7 +48,7 @@ version = "2"
optional = true
[dependencies.env_logger]
-version = "0.8"
+version = "0.9.0"
optional = true
[dependencies.lazy_static]
@@ -85,7 +84,7 @@ version = "1.0.1"
version = "1"
[dependencies.which]
-version = "3.0"
+version = "4.2.1"
optional = true
default-features = false
[dev-dependencies.clap]
@@ -97,6 +96,9 @@ version = "0.1"
[dev-dependencies.shlex]
version = "1"
+[dev-dependencies.tempfile]
+version = "3"
+
[features]
default = ["logging", "clap", "runtime", "which-rustfmt"]
logging = ["env_logger", "log"]