aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2021-07-15 01:27:15 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2021-07-15 01:27:15 +0000
commitdfc5e95ef092b6b4b72c49a2b6ccf01b31878981 (patch)
treec73b9c36b54c610427128761545e6fb08eff13d2 /Cargo.toml
parent821d2a074bc11e3cd81c9156702d3ec6fb5f2228 (diff)
parentc9e0a669bf9267447aa6fc6533ab9f798e8255ae (diff)
downloadbyteorder-android12-mainline-conscrypt-release.tar.gz
Snap for 7550844 from c9e0a669bf9267447aa6fc6533ab9f798e8255ae to mainline-conscrypt-releaseandroid-mainline-12.0.0_r8android-mainline-12.0.0_r25android12-mainline-conscrypt-release
Change-Id: I1b3291fccfe6ad46169b69821569851770f7fb6b
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 5 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fb2acad..c71f90b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,17 +11,17 @@
# will likely look very different (and much more reasonable)
[package]
+edition = "2018"
name = "byteorder"
-version = "1.3.2"
+version = "1.4.3"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-build = "build.rs"
exclude = ["/ci/*"]
description = "Library for reading/writing numbers in big-endian and little-endian."
homepage = "https://github.com/BurntSushi/byteorder"
documentation = "https://docs.rs/byteorder"
readme = "README.md"
keywords = ["byte", "endian", "big-endian", "little-endian", "binary"]
-categories = ["encoding", "parsing"]
+categories = ["encoding", "parsing", "no-std"]
license = "Unlicense OR MIT"
repository = "https://github.com/BurntSushi/byteorder"
[profile.bench]
@@ -30,19 +30,14 @@ opt-level = 3
[lib]
name = "byteorder"
bench = false
-[dev-dependencies.doc-comment]
-version = "0.3"
-
[dev-dependencies.quickcheck]
-version = "0.8"
+version = "0.9.2"
default-features = false
[dev-dependencies.rand]
-version = "0.6"
+version = "0.7"
[features]
default = ["std"]
i128 = []
std = []
-[badges.travis-ci]
-repository = "BurntSushi/byteorder"