aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 16 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1d72a8c..bb015ea 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,17 +3,16 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "command-fds"
-version = "0.2.1"
+version = "0.2.2"
authors = ["Andrew Walbran <qwandor@google.com>"]
description = "A library for passing arbitrary file descriptors when spawning child processes."
keywords = ["command", "process", "child", "subprocess", "fd"]
@@ -25,3 +24,14 @@ version = "0.22.0"
[dependencies.thiserror]
version = "1.0.24"
+
+[dependencies.tokio-crate]
+version = "^1.0"
+features = ["process"]
+optional = true
+default-features = false
+package = "tokio"
+
+[features]
+default = []
+tokio = ["tokio-crate"]