aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml99
1 files changed, 74 insertions, 25 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 26e1e10..b918ca5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,28 +3,39 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "criterion"
-version = "0.3.5"
-authors = ["Jorge Aparicio <japaricious@gmail.com>", "Brook Heisler <brookheisler@gmail.com>"]
+version = "0.4.0"
+authors = [
+ "Jorge Aparicio <japaricious@gmail.com>",
+ "Brook Heisler <brookheisler@gmail.com>",
+]
exclude = ["book/*"]
description = "Statistics-driven micro-benchmarking library"
homepage = "https://bheisler.github.io/criterion.rs/book/index.html"
readme = "README.md"
-keywords = ["criterion", "benchmark"]
+keywords = [
+ "criterion",
+ "benchmark",
+]
categories = ["development-tools::profiling"]
license = "Apache-2.0/MIT"
repository = "https://github.com/bheisler/criterion.rs"
+
[package.metadata.docs.rs]
-features = ["async_futures", "async_smol", "async_std", "async_tokio"]
+features = [
+ "async_futures",
+ "async_smol",
+ "async_std",
+ "async_tokio",
+]
[lib]
bench = false
@@ -32,25 +43,34 @@ bench = false
[[bench]]
name = "bench_main"
harness = false
+
+[dependencies.anes]
+version = "0.1.4"
+
[dependencies.async-std]
version = "1.9"
optional = true
[dependencies.atty]
-version = "0.2"
+version = "0.2.6"
[dependencies.cast]
-version = "0.2"
+version = "0.3"
+
+[dependencies.ciborium]
+version = "0.2.0"
[dependencies.clap]
-version = "2.33"
+version = "3.1"
+features = ["std"]
default-features = false
[dependencies.criterion-plot]
-version = "0.4.4"
+version = "0.5.0"
[dependencies.csv]
version = "1.1"
+optional = true
[dependencies.futures]
version = "0.3"
@@ -65,6 +85,7 @@ version = "1.4"
[dependencies.num-traits]
version = "0.2"
+features = ["std"]
default-features = false
[dependencies.oorandom]
@@ -72,23 +93,26 @@ version = "11.1"
[dependencies.plotters]
version = "^0.3.1"
-features = ["svg_backend", "area_series", "line_series"]
+features = [
+ "svg_backend",
+ "area_series",
+ "line_series",
+]
+optional = true
default-features = false
[dependencies.rayon]
version = "1.3"
+optional = true
[dependencies.regex]
-version = "1.3"
+version = "1.5"
features = ["std"]
default-features = false
[dependencies.serde]
version = "1.0"
-[dependencies.serde_cbor]
-version = "0.11"
-
[dependencies.serde_derive]
version = "1.0"
@@ -111,6 +135,7 @@ default-features = false
[dependencies.walkdir]
version = "2.3"
+
[dev-dependencies.approx]
version = "0.5.0"
@@ -131,15 +156,39 @@ version = "3.2.0"
[features]
async = ["futures"]
-async_futures = ["futures/executor", "async"]
-async_smol = ["smol", "async"]
-async_std = ["async-std", "async"]
-async_tokio = ["tokio", "async"]
+async_futures = [
+ "futures/executor",
+ "async",
+]
+async_smol = [
+ "smol",
+ "async",
+]
+async_std = [
+ "async-std",
+ "async",
+]
+async_tokio = [
+ "tokio",
+ "async",
+]
cargo_bench_support = []
-csv_output = []
-default = ["cargo_bench_support"]
+csv_output = ["csv"]
+default = [
+ "rayon",
+ "plotters",
+ "cargo_bench_support",
+]
html_reports = []
real_blackbox = []
-stable = ["async_futures", "async_smol", "async_tokio", "async_std"]
+stable = [
+ "csv_output",
+ "html_reports",
+ "async_futures",
+ "async_smol",
+ "async_tokio",
+ "async_std",
+]
+
[badges.maintenance]
status = "passively-maintained"