aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml46
1 files changed, 33 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 97f3df3..abacbe2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,25 +3,33 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
+rust-version = "1.36"
name = "crossbeam-epoch"
-version = "0.9.5"
-authors = ["The Crossbeam Project Developers"]
+version = "0.9.7"
description = "Epoch-based garbage collection"
homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-epoch"
-documentation = "https://docs.rs/crossbeam-epoch"
-keywords = ["lock-free", "rcu", "atomic", "garbage"]
-categories = ["concurrency", "memory-management", "no-std"]
+keywords = [
+ "lock-free",
+ "rcu",
+ "atomic",
+ "garbage",
+]
+categories = [
+ "concurrency",
+ "memory-management",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/crossbeam-rs/crossbeam"
+
[dependencies.cfg-if]
version = "1"
@@ -43,15 +51,27 @@ version = "0.6"
[dependencies.scopeguard]
version = "1.1.0"
default-features = false
+
[dev-dependencies.rand]
version = "0.8"
[features]
alloc = []
default = ["std"]
-loom = ["loom-crate", "crossbeam-utils/loom"]
-nightly = ["crossbeam-utils/nightly", "const_fn"]
-std = ["alloc", "crossbeam-utils/std", "lazy_static"]
+loom = [
+ "loom-crate",
+ "crossbeam-utils/loom",
+]
+nightly = [
+ "crossbeam-utils/nightly",
+ "const_fn",
+]
+std = [
+ "alloc",
+ "crossbeam-utils/std",
+ "lazy_static",
+]
+
[target."cfg(crossbeam_loom)".dependencies.loom-crate]
version = "0.5"
optional = true