aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml58
1 files changed, 37 insertions, 21 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 707e4e2..56e3597 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,27 +3,42 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.60"
name = "csv"
-version = "1.1.6"
+version = "1.2.0"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-exclude = ["/.travis.yml", "/appveyor.yml", "/ci/*", "/scripts/*"]
+exclude = [
+ "/.github",
+ "/ci/*",
+ "/scripts/*",
+]
description = "Fast CSV parsing with support for serde."
homepage = "https://github.com/BurntSushi/rust-csv"
-documentation = "http://burntsushi.net/rustdoc/csv/"
+documentation = "https://docs.rs/csv"
readme = "README.md"
-keywords = ["csv", "comma", "parser", "delimited", "serde"]
-categories = ["encoding", "parser-implementations"]
+keywords = [
+ "csv",
+ "comma",
+ "parser",
+ "delimited",
+ "serde",
+]
+categories = [
+ "encoding",
+ "parser-implementations",
+]
license = "Unlicense/MIT"
repository = "https://github.com/BurntSushi/rust-csv"
+resolver = "2"
+
[profile.bench]
debug = true
@@ -32,26 +47,27 @@ debug = true
[lib]
bench = false
-[dependencies.bstr]
-version = "0.2.1"
-features = ["serde1"]
[dependencies.csv-core]
-version = "0.1.6"
+version = "0.1.10"
[dependencies.itoa]
-version = "0.4.3"
+version = "1"
[dependencies.ryu]
version = "1"
[dependencies.serde]
version = "1.0.55"
+
+[dev-dependencies.bstr]
+version = "1.2.0"
+features = [
+ "alloc",
+ "serde",
+]
+default-features = false
+
[dev-dependencies.serde]
version = "1.0.55"
features = ["derive"]
-[badges.appveyor]
-repository = "BurntSushi/rust-csv"
-
-[badges.travis-ci]
-repository = "BurntSushi/rust-csv"