aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2023-07-07 01:02:57 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2023-07-07 01:02:57 +0000
commit8ec7502ba91c052728652343f319f80f1790d715 (patch)
treeec71d9fe7f4d8ff8e6f220a564a6506a0c779c13 /Cargo.toml
parentef45c9a988bed4242aab54c400b5c397b6c832ba (diff)
parent4a6abca8da952da053a9642391c284d54cd512d8 (diff)
downloadfutures-channel-android14-mainline-cellbroadcast-release.tar.gz
Change-Id: I610fd1ceed38c282c8f308fa94f5312a836b7cb2
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d0a13f6..869d735 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,11 +13,12 @@
edition = "2018"
rust-version = "1.45"
name = "futures-channel"
-version = "0.3.21"
+version = "0.3.26"
description = """
Channels for asynchronous communication using futures-rs.
"""
homepage = "https://rust-lang.github.io/futures-rs"
+readme = "README.md"
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/futures-rs"
@@ -29,15 +30,17 @@ rustdoc-args = [
]
[dependencies.futures-core]
-version = "0.3.21"
+version = "0.3.26"
default-features = false
[dependencies.futures-sink]
-version = "0.3.21"
+version = "0.3.26"
optional = true
default-features = false
[dev-dependencies]
+futures = "0.3.21"
+futures-test = "0.3.21"
[features]
alloc = ["futures-core/alloc"]