aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 8 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c34920a..4c95345 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2021"
rust-version = "1.58.1"
name = "glam"
-version = "0.25.0"
+version = "0.23.0"
authors = ["Cameron Hart <cameron.hart@gmail.com>"]
description = "A simple and fast 3D math library for games and graphics"
readme = "README.md"
@@ -89,17 +89,17 @@ optional = true
default-features = false
[dependencies.bytemuck]
-version = "1.9"
+version = "1.5"
optional = true
default-features = false
-[dependencies.libm]
-version = "0.2"
+[dependencies.mint]
+version = "0.5.8"
optional = true
default-features = false
-[dependencies.mint]
-version = "0.5.8"
+[dependencies.num-traits]
+version = "0.2.14"
optional = true
default-features = false
@@ -111,20 +111,16 @@ default-features = false
[dependencies.rkyv]
version = "0.7"
optional = true
-default-features = false
[dependencies.serde]
version = "1.0"
+features = ["derive"]
optional = true
default-features = false
[dev-dependencies.rand_xoshiro]
version = "0.6"
-[dev-dependencies.rkyv]
-version = "0.7"
-features = ["size_32"]
-
[dev-dependencies.serde_json]
version = "1.0"
@@ -135,6 +131,7 @@ debug-glam-assert = []
default = ["std"]
fast-math = []
glam-assert = []
+libm = ["num-traits/libm"]
scalar-math = []
std = []