summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 21 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 52cb1a5..be58771 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,22 +3,25 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "grpcio-compiler"
-version = "0.9.0"
+version = "0.12.1"
authors = ["The TiKV Project Developers"]
description = "gRPC compiler for grpcio"
homepage = "https://github.com/tikv/grpc-rs"
documentation = "https://docs.rs/grpcio-compiler"
-keywords = ["compiler", "grpc", "protobuf"]
+keywords = [
+ "compiler",
+ "grpc",
+ "protobuf",
+]
categories = ["network-programming"]
license = "Apache-2.0"
repository = "https://github.com/tikv/grpc-rs"
@@ -30,20 +33,21 @@ required-features = ["protobuf-codec"]
[[bin]]
name = "grpc_rust_prost"
required-features = ["prost-codec"]
+
[dependencies.derive-new]
version = "0.5"
optional = true
[dependencies.prost]
-version = "0.7"
+version = "0.11"
optional = true
[dependencies.prost-build]
-version = "0.7"
+version = "0.11"
optional = true
[dependencies.prost-types]
-version = "0.7"
+version = "0.11"
optional = true
[dependencies.protobuf]
@@ -56,5 +60,11 @@ optional = true
[features]
default = ["protobuf-codec"]
-prost-codec = ["prost-build", "prost-types", "prost", "derive-new", "tempfile"]
+prost-codec = [
+ "prost-build",
+ "prost-types",
+ "prost",
+ "derive-new",
+ "tempfile",
+]
protobuf-codec = ["protobuf"]