aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 7 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b03eb7c..c8ccf28 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,7 @@
[package]
edition = "2018"
name = "grpcio"
-version = "0.7.1"
+version = "0.8.2"
authors = ["The TiKV Project Developers"]
autoexamples = false
description = "The rust language implementation of gRPC, base on the gRPC c core library."
@@ -29,14 +29,15 @@ all-features = true
[profile.release]
debug = true
[dependencies.bytes]
-version = "0.5"
+version = "1.0"
optional = true
[dependencies.futures]
version = "0.3"
[dependencies.grpcio-sys]
-version = "0.7"
+version = "0.8"
+default-features = false
[dependencies.libc]
version = "0.2"
@@ -48,7 +49,7 @@ version = "0.4"
version = "0.11"
[dependencies.prost]
-version = "0.6"
+version = "0.7"
optional = true
[dependencies.protobuf]
@@ -56,12 +57,13 @@ version = "2.0"
optional = true
[features]
-default = ["protobuf-codec", "secure"]
+default = ["protobuf-codec", "secure", "use-bindgen"]
no-omit-frame-pointer = ["grpcio-sys/no-omit-frame-pointer"]
openssl = ["secure", "grpcio-sys/openssl"]
openssl-vendored = ["secure", "grpcio-sys/openssl-vendored"]
prost-codec = ["prost", "bytes"]
protobuf-codec = ["protobuf"]
secure = ["grpcio-sys/secure"]
+use-bindgen = ["grpcio-sys/use-bindgen"]
[badges.travis-ci]
repository = "tikv/grpc-rs"