aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 14 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c122803..73f965d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,8 +13,9 @@
[package]
edition = "2018"
name = "half"
-version = "1.6.0"
+version = "1.7.1"
authors = ["Kathryn Long <squeeself@gmail.com>"]
+exclude = ["/ci", "/*.yml"]
description = "Half-precision floating point f16 and bf16 types for Rust implementing the IEEE 754-2008 standard binary16 and bfloat16 types."
readme = "README.md"
keywords = ["f16", "bfloat16", "no_std"]
@@ -22,11 +23,22 @@ categories = ["no-std", "data-structures", "encoding"]
license = "MIT/Apache-2.0"
repository = "https://github.com/starkat99/half-rs"
[package.metadata.docs.rs]
-features = ["std", "serde"]
+features = ["std", "serde", "bytemuck", "num-traits"]
[[bench]]
name = "convert"
harness = false
+[dependencies.bytemuck]
+version = "1.4.1"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.num-traits]
+version = "0.2.14"
+optional = true
+default-features = false
+
[dependencies.serde]
version = "1.0"
features = ["derive"]