aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 24 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fc9c28d..7990368 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,25 +3,41 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "heck"
-version = "0.3.3"
+version = "0.4.1"
authors = ["Without Boats <woboats@gmail.com>"]
-include = ["src/**/*", "LICENSE-*", "README.md", "CHANGELOG.md"]
+include = [
+ "src/**/*",
+ "LICENSE-*",
+ "README.md",
+ "CHANGELOG.md",
+]
description = "heck is a case conversion library."
homepage = "https://github.com/withoutboats/heck"
documentation = "https://docs.rs/heck"
readme = "README.md"
-keywords = ["string", "case", "camel", "snake", "unicode"]
+keywords = [
+ "string",
+ "case",
+ "camel",
+ "snake",
+ "unicode",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/withoutboats/heck"
+
[dependencies.unicode-segmentation]
version = "1.2.0"
+optional = true
+
+[features]
+default = []
+unicode = ["unicode-segmentation"]