aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJiyong Park <jiyong@google.com>2021-06-22 16:47:17 +0900
committerJiyong Park <jiyong@google.com>2021-06-22 17:13:23 +0900
commitd7178e8a4e3e5f7ca00249ce8244b96d12eb217f (patch)
treefa72127b3c83c381efdb91cb30f750a586b66295 /Cargo.toml
parentaad8ae1c2c3b2280ab21be37c7b07149efeb7b9f (diff)
downloadkernlog-d7178e8a4e3e5f7ca00249ce8244b96d12eb217f.tar.gz
Import kernlog 0.3.1
Bug: 190383239 Test: m Change-Id: I5b591607d45a9478ae97efb82e74446a3183dbe5
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..480748d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "kernlog"
+version = "0.3.1"
+description = "Kernel logger implementation (for low level logging to `/dev/kmsg`)."
+authors = ["Konstantin Stepanov <me@kstep.me>"]
+readme = "README.md"
+repository = "https://github.com/kstep/kernlog.rs.git"
+documentation = "http://kstep.me/kernlog.rs/kernlog/index.html"
+license = "MIT"
+keywords = ["kmsg", "log", "logger", "kernel", "dmesg"]
+edition = "2018"
+
+[dependencies]
+log = { version = "0.4", features = ["std"] }
+libc = "0.2"