summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 16 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 63cf8c3..b1ff8c4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,13 +12,22 @@
[package]
edition = "2018"
name = "lock_api"
-version = "0.4.6"
+version = "0.4.9"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
description = "Wrappers to create fully-featured Mutex and RwLock types. Compatible with no_std."
-keywords = ["mutex", "rwlock", "lock", "no_std"]
-categories = ["concurrency", "no-std"]
-license = "Apache-2.0/MIT"
+keywords = [
+ "mutex",
+ "rwlock",
+ "lock",
+ "no_std",
+]
+categories = [
+ "concurrency",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
repository = "https://github.com/Amanieu/parking_lot"
+
[dependencies.owning_ref]
version = "0.4.1"
optional = true
@@ -32,6 +41,9 @@ version = "1.0.126"
optional = true
default-features = false
+[build-dependencies.autocfg]
+version = "1.1.0"
+
[features]
arc_lock = []
nightly = []