aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml138
1 files changed, 120 insertions, 18 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 122c1af..0afc445 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,17 +11,41 @@
[package]
edition = "2018"
-rust-version = "1.46"
+rust-version = "1.56"
name = "nix"
-version = "0.23.1"
+version = "0.26.2"
authors = ["The nix-rust Project Developers"]
-include = ["src/**/*", "test/**/*", "LICENSE", "README.md", "CHANGELOG.md"]
+include = [
+ "src/**/*",
+ "test/**/*",
+ "LICENSE",
+ "README.md",
+ "CHANGELOG.md",
+]
description = "Rust friendly bindings to *nix APIs"
+readme = "README.md"
categories = ["os::unix-apis"]
license = "MIT"
repository = "https://github.com/nix-rust/nix"
+
[package.metadata.docs.rs]
-targets = ["x86_64-unknown-linux-gnu", "aarch64-linux-android", "x86_64-apple-darwin", "aarch64-apple-ios", "x86_64-unknown-freebsd", "x86_64-unknown-openbsd", "x86_64-unknown-netbsd", "x86_64-unknown-dragonfly", "x86_64-fuchsia", "x86_64-unknown-redox", "x86_64-unknown-illumos"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+targets = [
+ "x86_64-unknown-linux-gnu",
+ "aarch64-linux-android",
+ "x86_64-apple-darwin",
+ "aarch64-apple-ios",
+ "x86_64-unknown-freebsd",
+ "x86_64-unknown-openbsd",
+ "x86_64-unknown-netbsd",
+ "x86_64-unknown-dragonfly",
+ "x86_64-fuchsia",
+ "x86_64-unknown-redox",
+ "x86_64-unknown-illumos",
+]
[[test]]
name = "test"
@@ -36,10 +60,6 @@ name = "test-clearenv"
path = "test/test_clearenv.rs"
[[test]]
-name = "test-lio-listio-resubmit"
-path = "test/sys/test_lio_listio_resubmit.rs"
-
-[[test]]
name = "test-mount"
path = "test/test_mount.rs"
harness = false
@@ -47,6 +67,7 @@ harness = false
[[test]]
name = "test-ptymaster-drop"
path = "test/test_ptymaster_drop.rs"
+
[dependencies.bitflags]
version = "1.1"
@@ -54,30 +75,111 @@ version = "1.1"
version = "1.0"
[dependencies.libc]
-version = "0.2.102"
+version = "0.2.137"
features = ["extra_traits"]
+
+[dependencies.pin-utils]
+version = "0.1.0"
+optional = true
+
+[dependencies.static_assertions]
+version = "1"
+
[dev-dependencies.assert-impl]
version = "0.1"
[dev-dependencies.lazy_static]
-version = "1.2"
+version = "1.4"
[dev-dependencies.parking_lot]
-version = "0.11.2"
+version = "0.12"
[dev-dependencies.rand]
version = "0.8"
[dev-dependencies.semver]
-version = "1.0.0"
+version = "1.0.7"
[dev-dependencies.tempfile]
-version = "3.2.0"
+version = "3.3.0"
+
+[features]
+acct = []
+aio = ["pin-utils"]
+default = [
+ "acct",
+ "aio",
+ "dir",
+ "env",
+ "event",
+ "feature",
+ "fs",
+ "hostname",
+ "inotify",
+ "ioctl",
+ "kmod",
+ "mman",
+ "mount",
+ "mqueue",
+ "net",
+ "personality",
+ "poll",
+ "process",
+ "pthread",
+ "ptrace",
+ "quota",
+ "reboot",
+ "resource",
+ "sched",
+ "signal",
+ "socket",
+ "term",
+ "time",
+ "ucontext",
+ "uio",
+ "user",
+ "zerocopy",
+]
+dir = ["fs"]
+env = []
+event = []
+feature = []
+fs = []
+hostname = []
+inotify = []
+ioctl = []
+kmod = []
+mman = []
+mount = ["uio"]
+mqueue = ["fs"]
+net = ["socket"]
+personality = []
+poll = []
+process = []
+pthread = []
+ptrace = ["process"]
+quota = []
+reboot = []
+resource = []
+sched = ["process"]
+signal = ["process"]
+socket = ["memoffset"]
+term = []
+time = []
+ucontext = ["signal"]
+uio = []
+user = ["feature"]
+zerocopy = [
+ "fs",
+ "uio",
+]
+
[target."cfg(any(target_os = \"android\", target_os = \"linux\"))".dev-dependencies.caps]
-version = "0.5.1"
+version = "0.5.3"
+
[target."cfg(not(target_os = \"redox\"))".dependencies.memoffset]
-version = "0.6.3"
-[target."cfg(target_os = \"dragonfly\")".build-dependencies.cc]
-version = "1"
+version = "0.7"
+optional = true
+
[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
-version = "0.1"
+version = "0.4"