aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 16 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0a7ae1e..a183443 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,28 +3,30 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
+rust-version = "1.31"
name = "no-panic"
-version = "0.1.15"
+version = "0.1.21"
authors = ["David Tolnay <dtolnay@gmail.com>"]
description = "Attribute macro to require that the compiler prove a function can't ever panic."
documentation = "https://docs.rs/no-panic"
readme = "README.md"
license = "MIT OR Apache-2.0"
repository = "https://github.com/dtolnay/no-panic"
+
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
[lib]
proc-macro = true
+
[dependencies.proc-macro2]
version = "1.0"
@@ -34,5 +36,13 @@ version = "1.0"
[dependencies.syn]
version = "1.0"
features = ["full"]
+
+[dev-dependencies.rustversion]
+version = "1.0.9"
+
[dev-dependencies.tempfile]
version = "3.0"
+
+[dev-dependencies.trybuild]
+version = "1.0.69"
+features = ["diff"]