aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid LeGare <legare@google.com>2022-03-02 16:21:20 +0000
committerDavid LeGare <legare@google.com>2022-03-02 16:21:20 +0000
commit061b49860e4f94f264cb1202713ebc68304e1292 (patch)
tree63d0f458744432dcb2f047ae214ace796e4a431d /Cargo.toml
parent7132b01d1e71be9dbca5a716c8e06ab1f59e0038 (diff)
downloadnom-061b49860e4f94f264cb1202713ebc68304e1292.tar.gz
Update nom to 7.1.0
Test: cd external/rust/crates && atest --host -c Change-Id: Ia47ec422de996e2b4f54422817a49578a2d8eb75
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml55
1 files changed, 9 insertions, 46 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1a14020..6e38fa0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "nom"
-version = "7.0.0"
+version = "7.1.0"
authors = ["contact@geoffroycouprie.com"]
include = ["CHANGELOG.md", "LICENSE", "README.md", ".gitignore", "Cargo.toml", "src/*.rs", "src/*/*.rs", "tests/*.rs", "doc/nom_recipes.md", "build.rs"]
autoexamples = false
@@ -31,15 +31,16 @@ lto = true
codegen-units = 1
debug = true
-[lib]
-bench = false
-
[[example]]
name = "json"
path = "examples/json.rs"
required-features = ["alloc"]
[[example]]
+name = "iterator"
+path = "examples/iterator.rs"
+
+[[example]]
name = "s_expression"
path = "examples/s_expression.rs"
required-features = ["alloc"]
@@ -57,9 +58,6 @@ name = "arithmetic_ast"
required-features = ["alloc"]
[[test]]
-name = "blockbuf-arithmetic"
-
-[[test]]
name = "css"
[[test]]
@@ -100,51 +98,16 @@ name = "reborrow_fold"
[[test]]
name = "fnmut"
required-features = ["alloc"]
-
-[[bench]]
-name = "arithmetic"
-path = "benches/arithmetic.rs"
-harness = false
-
-[[bench]]
-name = "number"
-path = "benches/number.rs"
-harness = false
-
-[[bench]]
-name = "http"
-path = "benches/http.rs"
-harness = false
-
-[[bench]]
-name = "ini"
-path = "benches/ini.rs"
-harness = false
-
-[[bench]]
-name = "ini_str"
-path = "benches/ini_str.rs"
-harness = false
-
-[[bench]]
-name = "json"
-path = "benches/json.rs"
-harness = false
[dependencies.memchr]
-version = "2.0"
+version = "2.3"
default-features = false
[dependencies.minimal-lexical]
-version = "0.1.2"
-[dev-dependencies.criterion]
-version = "0.3"
-
+version = "0.2.0"
+default-features = false
[dev-dependencies.doc-comment]
version = "0.3"
-[dev-dependencies.jemallocator]
-version = "^0.3"
-
[dev-dependencies.proptest]
version = "1.0.0"
[build-dependencies.version_check]
@@ -154,7 +117,7 @@ version = "0.9"
alloc = []
default = ["std"]
docsrs = []
-std = ["alloc", "memchr/use_std"]
+std = ["alloc", "memchr/std", "minimal-lexical/std"]
[badges.coveralls]
branch = "master"
repository = "Geal/nom"