summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMike Yu <yumike@google.com>2022-09-20 09:43:48 +0000
committerMike Yu <yumike@google.com>2022-09-26 06:52:41 +0000
commit1780ec6409ba57b3bc63f44426cbb47779e82c77 (patch)
tree3d9eeb7745c7222a7b9cf8f74e49774c94a99d66 /Cargo.toml
parentb41fda302f17ba1fcab187595298ad3665e9c9a7 (diff)
downloadoctets-1780ec6409ba57b3bc63f44426cbb47779e82c77.tar.gz
Initial import of octets-0.1.0
Since the source doesn't contain a license file, this change is made from: $ get_rust_pkg.py -o /tmp octets-0.1.0 $ cp -R /tmp/octets-0.1.0/. . $ cp ${ANDROID_BUILD_TOP}/external/rust/crates/quiche/LICENSE . $ add3prf.py Bug: 233719694 Test: N/A Change-Id: Icdd83bb76f0ebfd87022bc18abb6a966ffe0a368
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..0202601
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,21 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "octets"
+version = "0.1.0"
+authors = ["Alessandro Ghedini <alessandro@ghedini.me>"]
+description = "Zero-copy abstraction for parsing and constructing network packets"
+keywords = ["quic", "http3"]
+categories = ["network-programming"]
+license = "BSD-2-Clause"
+repository = "https://github.com/cloudflare/quiche"