summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 8 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 361186b..83d9f23 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,8 +11,9 @@
[package]
edition = "2018"
+rust-version = "1.49.0"
name = "parking_lot_core"
-version = "0.9.7"
+version = "0.9.9"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
description = "An advanced API for creating custom synchronization primitives."
keywords = [
@@ -26,6 +27,9 @@ categories = ["concurrency"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/Amanieu/parking_lot"
+[package.metadata.docs.rs]
+rustdoc-args = ["--generate-link-to-definition"]
+
[dependencies.backtrace]
version = "0.3.60"
optional = true
@@ -53,16 +57,10 @@ deadlock_detection = [
nightly = []
[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.2.8"
+version = "0.4"
[target."cfg(unix)".dependencies.libc]
version = "0.2.95"
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.45.0"
-features = [
- "Win32_Foundation",
- "Win32_System_LibraryLoader",
- "Win32_System_SystemServices",
- "Win32_System_WindowsProgramming",
-]
+[target."cfg(windows)".dependencies.windows-targets]
+version = "0.48.0"