summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHenri Chataing <henrichataing@google.com>2022-02-08 11:30:38 +0100
committerHenri Chataing <henrichataing@google.com>2022-02-18 11:26:52 +0100
commitc608b2fd27f204fd748295983c4b93424ee6aa24 (patch)
treec8d7f7a09c5cd8ed50f7e84684bd34868ad56527 /Cargo.toml
parent099cc31ed68e26a96fcab1fdc06b5af9fd5ade43 (diff)
downloadpest_generator-c608b2fd27f204fd748295983c4b93424ee6aa24.tar.gz
Import pest_generator crate.
Bug: 218416559 Change-Id: I1bedd7fb18413eb6638f5d3df0cd4d099cd83fee
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..1ef45f9
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "pest_generator"
+version = "2.1.3"
+authors = ["DragoČ™ Tiselice <dragostiselice@gmail.com>"]
+description = "pest code generator"
+homepage = "https://pest-parser.github.io/"
+documentation = "https://docs.rs/pest"
+readme = "_README.md"
+keywords = ["pest", "generator"]
+categories = ["parsing"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/pest-parser/pest"
+[dependencies.pest]
+version = "2.1.0"
+
+[dependencies.pest_meta]
+version = "2.1.0"
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "1.0"
+[badges.codecov]
+repository = "pest-parser/pest"
+
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+repository = "pest-parser/pest"