aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 11 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 563806a..92774c9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,28 +3,28 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
+# to registry (e.g., crates.io) dependencies
#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
[package]
edition = "2018"
-rust-version = "1.37"
name = "pin-project-lite"
-version = "0.2.8"
-exclude = ["/.*", "/tools"]
+version = "0.2.4"
+authors = ["Taiki Endo <te316e89@gmail.com>"]
+exclude = ["/.github", "/scripts"]
description = "A lightweight version of pin-project written with declarative macros.\n"
+documentation = "https://docs.rs/pin-project-lite"
+readme = "README.md"
keywords = ["pin", "macros"]
categories = ["no-std", "rust-patterns"]
license = "Apache-2.0 OR MIT"
repository = "https://github.com/taiki-e/pin-project-lite"
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
-[dev-dependencies.macrotest]
-version = "1.0.8"
-
[dev-dependencies.rustversion]
version = "1"
@@ -32,4 +32,4 @@ version = "1"
version = "1"
[dev-dependencies.trybuild]
-version = "1.0.49"
+version = "1"