aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 10 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4134e67..197d26d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,27 +13,30 @@
[package]
edition = "2018"
name = "remain"
-version = "0.1.3"
+version = "0.2.2"
authors = ["David Tolnay <dtolnay@gmail.com>"]
description = "Compile-time checks that an enum, struct, or match is written in sorted order."
documentation = "https://docs.rs/remain"
readme = "README.md"
license = "MIT OR Apache-2.0"
repository = "https://github.com/dtolnay/remain"
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
[lib]
proc-macro = true
[dependencies.proc-macro2]
-version = "0.4"
+version = "1.0"
[dependencies.quote]
-version = "0.6"
+version = "1.0"
[dependencies.syn]
-version = "0.15"
+version = "1.0"
features = ["full", "visit-mut"]
-[dev-dependencies.select-rustc]
-version = "0.1"
+[dev-dependencies.rustversion]
+version = "1.0"
[dev-dependencies.trybuild]
-version = "1.0"
+version = "1.0.19"
+features = ["diff"]