aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHaibo Huang <hhb@google.com>2020-08-22 02:25:09 -0700
committerHaibo Huang <hhb@google.com>2020-09-10 15:26:36 -0700
commitb5372b7e695e7086f679629cae6864b785959112 (patch)
tree7627b35b901cea37bfd0a90396c150eddd1e526b /Cargo.toml
parent4cc969aae626ee2e932d751097d57a7cbf79dd0e (diff)
downloadrusqlite-b5372b7e695e7086f679629cae6864b785959112.tar.gz
Upgrade rust/crates/rusqlite to 0.24.0
Test: make Change-Id: Ifa96d283fdbe3a0ba3190c3c8b13f8740507d34f
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 12 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3add3fe..6842cfa 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,7 @@
[package]
edition = "2018"
name = "rusqlite"
-version = "0.23.1"
+version = "0.24.0"
authors = ["The rusqlite developers"]
description = "Ergonomic wrapper for SQLite"
documentation = "http://docs.rs/rusqlite/"
@@ -25,7 +25,7 @@ repository = "https://github.com/rusqlite/rusqlite"
[package.metadata.docs.rs]
all-features = false
default-target = "x86_64-unknown-linux-gnu"
-features = ["backup", "blob", "chrono", "collation", "functions", "limits", "load_extension", "serde_json", "trace", "url", "vtab", "window", "modern_sqlite"]
+features = ["backup", "blob", "chrono", "collation", "functions", "limits", "load_extension", "serde_json", "time", "trace", "url", "vtab", "window", "modern_sqlite", "column_decltype"]
no-default-features = true
[package.metadata.playground]
@@ -48,6 +48,10 @@ name = "vtab"
[[bench]]
name = "cache"
harness = false
+
+[[bench]]
+name = "exec"
+harness = false
[dependencies.bitflags]
version = "1.0"
@@ -75,7 +79,7 @@ version = "1.0"
optional = true
[dependencies.libsqlite3-sys]
-version = "0.18.0"
+version = "0.20.0"
[dependencies.lru-cache]
version = "0.1"
@@ -91,7 +95,8 @@ optional = true
version = "1.3"
[dependencies.time]
-version = "0.1.0"
+version = "0.2"
+optional = true
[dependencies.url]
version = "2.0"
@@ -128,9 +133,10 @@ backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"]
bundled = ["libsqlite3-sys/bundled", "modern_sqlite"]
-bundled-full = ["array", "backup", "blob", "bundled", "chrono", "collation", "csvtab", "extra_check", "functions", "hooks", "i128_blob", "limits", "load_extension", "serde_json", "series", "trace", "unlock_notify", "url", "uuid", "vtab", "window"]
+bundled-full = ["array", "backup", "blob", "bundled", "chrono", "collation", "column_decltype", "csvtab", "extra_check", "functions", "hooks", "i128_blob", "limits", "load_extension", "serde_json", "series", "trace", "unlock_notify", "url", "uuid", "vtab", "window"]
bundled-windows = ["libsqlite3-sys/bundled-windows"]
collation = []
+column_decltype = []
csvtab = ["csv", "vtab"]
extra_check = []
functions = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
@@ -146,6 +152,7 @@ sqlcipher = ["libsqlite3-sys/sqlcipher"]
trace = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
unlock_notify = ["libsqlite3-sys/unlock_notify"]
vtab = ["libsqlite3-sys/min_sqlite_version_3_7_7", "lazy_static"]
+wasm32-wasi-vfs = ["libsqlite3-sys/wasm32-wasi-vfs"]
window = ["functions"]
with-asan = ["libsqlite3-sys/with-asan"]
[badges.appveyor]