aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml50
1 files changed, 34 insertions, 16 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 422755b..a646f02 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,31 +3,45 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.56"
name = "syn-mid"
-version = "0.5.3"
-authors = ["Taiki Endo <te316e89@gmail.com>"]
-exclude = ["/.github", "/scripts"]
-description = "Providing the features between \"full\" and \"derive\" of syn.\n"
-documentation = "https://docs.rs/syn-mid"
+version = "0.6.0"
+exclude = [
+ "/.*",
+ "/tools",
+]
+description = """
+Providing the features between \"full\" and \"derive\" of syn.
+"""
readme = "README.md"
-keywords = ["syn", "macros"]
-categories = ["development-tools::procedural-macro-helpers"]
+keywords = [
+ "syn",
+ "macros",
+]
+categories = [
+ "development-tools::procedural-macro-helpers",
+ "parser-implementations",
+]
license = "Apache-2.0 OR MIT"
repository = "https://github.com/taiki-e/syn-mid"
+
[package.metadata.docs.rs]
all-features = true
targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+doc-scrape-examples = false
+
[dependencies.proc-macro2]
-version = "1"
+version = "1.0.60"
default-features = false
[dependencies.quote]
@@ -35,8 +49,12 @@ version = "1"
default-features = false
[dependencies.syn]
-version = "1.0.44"
-features = ["parsing", "printing", "derive"]
+version = "2"
+features = [
+ "parsing",
+ "printing",
+ "derive",
+]
default-features = false
[features]