aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 17 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 90e5319..d773a90 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,28 +10,36 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
name = "thread_local"
-version = "1.1.4"
+version = "1.1.7"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
description = "Per-object thread-local storage"
documentation = "https://docs.rs/thread_local/"
readme = "README.md"
-keywords = ["thread_local", "concurrent", "thread"]
-license = "Apache-2.0/MIT"
+keywords = [
+ "thread_local",
+ "concurrent",
+ "thread",
+]
+license = "MIT OR Apache-2.0"
repository = "https://github.com/Amanieu/thread_local-rs"
[[bench]]
name = "thread_local"
harness = false
-required-features = ["criterion"]
-[dependencies.criterion]
-version = "0.3.3"
-optional = true
+
+[dependencies.cfg-if]
+version = "1.0.0"
[dependencies.once_cell]
version = "1.5.2"
-[dev-dependencies]
+[dev-dependencies.criterion]
+version = "0.4.0"
+
+[features]
+nightly = []
+
[badges.travis-ci]
repository = "Amanieu/thread_local-rs"