aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 11 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 221f2e7..51e9a96 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,10 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.49"
+edition = "2021"
+rust-version = "1.56"
name = "tokio-util"
-version = "0.7.7"
+version = "0.7.10"
authors = ["Tokio Contributors <team@tokio.rs>"]
description = """
Additional utilities for working with Tokio.
@@ -26,13 +26,13 @@ repository = "https://github.com/tokio-rs/tokio"
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = [
+rustc-args = [
"--cfg",
"docsrs",
"--cfg",
"tokio_unstable",
]
-rustc-args = [
+rustdoc-args = [
"--cfg",
"docsrs",
"--cfg",
@@ -57,14 +57,14 @@ version = "0.3.0"
optional = true
[dependencies.pin-project-lite]
-version = "0.2.0"
+version = "0.2.11"
[dependencies.slab]
version = "0.4.4"
optional = true
[dependencies.tokio]
-version = "1.22.0"
+version = "1.28.0"
features = ["sync"]
[dependencies.tracing]
@@ -85,6 +85,9 @@ version = "0.3.5"
[dev-dependencies.parking_lot]
version = "0.12.0"
+[dev-dependencies.tempfile]
+version = "3.1.0"
+
[dev-dependencies.tokio]
version = "1.0.0"
features = ["full"]
@@ -127,5 +130,5 @@ time = [
]
[target."cfg(tokio_unstable)".dependencies.hashbrown]
-version = "0.12.0"
+version = "0.14.0"
optional = true