aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml131
1 files changed, 131 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..221f2e7
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,131 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.49"
+name = "tokio-util"
+version = "0.7.7"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+description = """
+Additional utilities for working with Tokio.
+"""
+homepage = "https://tokio.rs"
+readme = "README.md"
+categories = ["asynchronous"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+ "--cfg",
+ "tokio_unstable",
+]
+rustc-args = [
+ "--cfg",
+ "docsrs",
+ "--cfg",
+ "tokio_unstable",
+]
+
+[dependencies.bytes]
+version = "1.0.0"
+
+[dependencies.futures-core]
+version = "0.3.0"
+
+[dependencies.futures-io]
+version = "0.3.0"
+optional = true
+
+[dependencies.futures-sink]
+version = "0.3.0"
+
+[dependencies.futures-util]
+version = "0.3.0"
+optional = true
+
+[dependencies.pin-project-lite]
+version = "0.2.0"
+
+[dependencies.slab]
+version = "0.4.4"
+optional = true
+
+[dependencies.tokio]
+version = "1.22.0"
+features = ["sync"]
+
+[dependencies.tracing]
+version = "0.1.25"
+features = ["std"]
+optional = true
+default-features = false
+
+[dev-dependencies.async-stream]
+version = "0.3.0"
+
+[dev-dependencies.futures]
+version = "0.3.0"
+
+[dev-dependencies.futures-test]
+version = "0.3.5"
+
+[dev-dependencies.parking_lot]
+version = "0.12.0"
+
+[dev-dependencies.tokio]
+version = "1.0.0"
+features = ["full"]
+
+[dev-dependencies.tokio-stream]
+version = "0.1"
+
+[dev-dependencies.tokio-test]
+version = "0.4.0"
+
+[features]
+__docs_rs = ["futures-util"]
+codec = ["tracing"]
+compat = ["futures-io"]
+default = []
+full = [
+ "codec",
+ "compat",
+ "io-util",
+ "time",
+ "net",
+ "rt",
+]
+io = []
+io-util = [
+ "io",
+ "tokio/rt",
+ "tokio/io-util",
+]
+net = ["tokio/net"]
+rt = [
+ "tokio/rt",
+ "tokio/sync",
+ "futures-util",
+ "hashbrown",
+]
+time = [
+ "tokio/time",
+ "slab",
+]
+
+[target."cfg(tokio_unstable)".dependencies.hashbrown]
+version = "0.12.0"
+optional = true