aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml55
1 files changed, 42 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4d687bb..5bec9cb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,32 +3,52 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
+rust-version = "1.61.0"
name = "webpki"
-version = "0.22.0"
+version = "0.22.4"
authors = ["Brian Smith <brian@briansmith.org>"]
-include = ["Cargo.toml", "LICENSE", "README.md", "src/calendar.rs", "src/cert.rs", "src/der.rs", "src/end_entity.rs", "src/error.rs", "src/name.rs", "src/name/dns_name.rs", "src/name/ip_address.rs", "src/name/verify.rs", "src/signed_data.rs", "src/time.rs", "src/trust_anchor.rs", "src/verify_cert.rs", "src/lib.rs", "src/data/**/*", "tests/dns_name_tests.rs", "tests/integration.rs", "tests/misc/serial_neg.der", "tests/misc/serial_zero.der", "tests/netflix/ca.der", "tests/netflix/ee.der", "tests/netflix/inter.der", "tests/ed25519/ca.der", "tests/ed25519/ee.der", "third-party/chromium/**/*"]
+include = [
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+ "src/**/*.rs",
+ "src/data/**/*",
+ "tests/dns_name_tests.rs",
+ "tests/integration.rs",
+ "tests/misc/serial_neg.der",
+ "tests/misc/serial_zero.der",
+ "tests/netflix/ca.der",
+ "tests/netflix/ee.der",
+ "tests/netflix/inter.der",
+ "tests/ed25519/ca.der",
+ "tests/ed25519/ee.der",
+ "third-party/chromium/**/*",
+]
description = "Web PKI X.509 Certificate Verification."
-documentation = "https://briansmith.org/rustdoc/webpki/"
readme = "README.md"
-categories = ["cryptography", "no-std"]
+categories = [
+ "cryptography",
+ "no-std",
+]
license-file = "LICENSE"
repository = "https://github.com/briansmith/webpki"
+
[package.metadata.docs.rs]
all-features = true
+
[profile.bench]
opt-level = 3
lto = true
codegen-units = 1
-debug = false
+debug = 0
debug-assertions = false
rpath = false
@@ -36,21 +56,30 @@ rpath = false
opt-level = 3
lto = true
codegen-units = 1
-debug = false
+debug = 0
debug-assertions = false
rpath = false
[lib]
name = "webpki"
+
[dependencies.ring]
-version = "0.16.19"
+version = "0.17.2"
default-features = false
[dependencies.untrusted]
-version = "0.7.1"
+version = "0.9"
+
[dev-dependencies.base64]
version = "0.9.1"
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
[features]
alloc = ["ring/alloc"]
std = ["alloc"]