aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 25 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 522276c..61cf661 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2021"
rust-version = "1.64.0"
name = "winnow"
-version = "0.5.14"
+version = "0.5.37"
include = [
"build.rs",
"src/**/*",
@@ -84,6 +84,12 @@ replace = """
[Unreleased]: https://github.com/winnow-rs/winnow/compare/{{tag_name}}...HEAD"""
search = "<!-- next-url -->"
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "src/lib.rs"
+replace = "blob/v{{version}}/CHANGELOG.md"
+search = 'blob/v.+\..+\..+/CHANGELOG.md'
+
[profile.bench]
lto = true
codegen-units = 1
@@ -142,12 +148,25 @@ required-features = ["alloc"]
name = "arithmetic"
path = "examples/arithmetic/bench.rs"
harness = false
+required-features = ["alloc"]
[[bench]]
name = "contains_token"
harness = false
[[bench]]
+name = "find_slice"
+harness = false
+
+[[bench]]
+name = "iter"
+harness = false
+
+[[bench]]
+name = "next_slice"
+harness = false
+
+[[bench]]
name = "number"
harness = false
@@ -208,6 +227,9 @@ version = "0.3.0"
[dev-dependencies.proptest]
version = "1.2.0"
+[dev-dependencies.rustc-hash]
+version = "1.1.0"
+
[dev-dependencies.snapbox]
version = "0.4.11"
features = ["examples"]
@@ -233,4 +255,6 @@ unstable-doc = [
"alloc",
"std",
"simd",
+ "unstable-recover",
]
+unstable-recover = []