aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2024-02-02 23:56:36 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2024-02-02 23:56:36 +0000
commit10ffb6bbcf05dc0a71bbf29006b34c8a80d15bd0 (patch)
tree906f9dd3bae52323bc6fde373383247e3f67f65a /Cargo.toml
parenteaa766f14935c0f26afc7f8225143d1dc261b6d7 (diff)
parentadfecb30ba9dc20ed624a80576a1a5aaad967491 (diff)
downloadzerocopy-simpleperf-release.tar.gz
Snap for 11400057 from adfecb30ba9dc20ed624a80576a1a5aaad967491 to simpleperf-releasesimpleperf-release
Change-Id: I0297460faebc208229f3940b3fe7ee5178e79d00
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 22 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 802ec0b..c4b1c9d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,23 +10,31 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
-rust-version = "1.61.0"
+edition = "2018"
+rust-version = "1.60.0"
name = "zerocopy"
-version = "0.7.5"
+version = "0.7.29"
authors = ["Joshua Liebow-Feeser <joshlf@google.com>"]
exclude = [".*"]
description = "Utilities for zero-copy parsing and serialization"
readme = "README.md"
-license = "BSD-2-Clause"
+license = "BSD-2-Clause OR Apache-2.0 OR MIT"
repository = "https://github.com/google/zerocopy"
[package.metadata.ci]
-pinned-nightly = "nightly-2023-05-25"
-pinned-stable = "1.69.0"
+pinned-nightly = "nightly-2023-12-04"
+pinned-stable = "1.74.0"
[package.metadata.docs.rs]
all-features = true
+rustdoc-args = [
+ "--cfg",
+ "doc_cfg",
+ "--generate-link-to-definition",
+]
+
+[package.metadata.playground]
+features = ["__internal_use_only_features_that_work_on_stable"]
[dependencies.byteorder]
version = "1.3"
@@ -34,12 +42,15 @@ optional = true
default-features = false
[dependencies.zerocopy-derive]
-version = "=0.7.5"
+version = "=0.7.29"
optional = true
[dev-dependencies.assert_matches]
version = "1.5"
+[dev-dependencies.elain]
+version = "0.3.0"
+
[dev-dependencies.itertools]
version = "0.11"
@@ -54,10 +65,11 @@ version = "1.0"
version = "1.1"
[dev-dependencies.trybuild]
-version = "=1.0.80"
+version = "=1.0.85"
+features = ["diff"]
[dev-dependencies.zerocopy-derive]
-version = "=0.7.5"
+version = "=0.7.29"
[features]
__internal_use_only_features_that_work_on_stable = [
@@ -72,4 +84,4 @@ simd = []
simd-nightly = ["simd"]
[target."cfg(any())".dependencies.zerocopy-derive]
-version = "=0.7.5"
+version = "=0.7.29"