aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHasini Gunasinghe <hasinitg@google.com>2022-09-09 22:35:37 +0000
committerHasini Gunasinghe <hasinitg@google.com>2022-10-04 21:51:37 +0000
commit5142b2ef96c507193f21c67cbcc1ab41dac14914 (patch)
treea2eb62acecd00e5712403003fcd9732c87e4196c /Cargo.toml
parent33c96294d5131838a51ba442a05d010ef9e19727 (diff)
downloadzeroize-5142b2ef96c507193f21c67cbcc1ab41dac14914.tar.gz
Import platform/external/rust/crates/zeroize
Bug: 239549209 Test: N/A Change-Id: Ib0dae0b0cf7aaa1a7f5c1f74c3ab5f1cb900ed11
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml62
1 files changed, 62 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..a70f551
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,62 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "zeroize"
+version = "1.5.7"
+authors = ["The RustCrypto Project Developers"]
+description = """
+Securely clear secrets from memory with a simple trait built on
+stable Rust primitives which guarantee memory is zeroed using an
+operation will not be 'optimized away' by the compiler.
+Uses a portable pure Rust implementation that works everywhere,
+even WASM!
+"""
+readme = "README.md"
+keywords = [
+ "memory",
+ "memset",
+ "secure",
+ "volatile",
+ "zero",
+]
+categories = [
+ "cryptography",
+ "memory-management",
+ "no-std",
+ "os",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/utils/tree/master/zeroize"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.zeroize_derive]
+version = "1.3"
+optional = true
+
+[features]
+aarch64 = []
+alloc = []
+default = ["alloc"]
+derive = ["zeroize_derive"]
+std = ["alloc"]