aboutsummaryrefslogtreecommitdiff
path: root/gen/build/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'gen/build/Cargo.toml')
-rw-r--r--gen/build/Cargo.toml27
1 files changed, 17 insertions, 10 deletions
diff --git a/gen/build/Cargo.toml b/gen/build/Cargo.toml
index 393fc1ce..ea19af89 100644
--- a/gen/build/Cargo.toml
+++ b/gen/build/Cargo.toml
@@ -1,31 +1,38 @@
[package]
name = "cxx-build"
-version = "1.0.54"
+version = "1.0.85"
authors = ["David Tolnay <dtolnay@gmail.com>"]
+categories = ["development-tools::build-utils", "development-tools::ffi"]
+description = "C++ code generator for integrating `cxx` crate into a Cargo build."
edition = "2018"
+exclude = ["build.rs"]
+homepage = "https://cxx.rs"
+keywords = ["ffi", "build-dependencies"]
license = "MIT OR Apache-2.0"
-description = "C++ code generator for integrating `cxx` crate into a Cargo build."
repository = "https://github.com/dtolnay/cxx"
-homepage = "https://cxx.rs"
-exclude = ["build.rs"]
-keywords = ["ffi"]
-categories = ["development-tools::ffi"]
+rust-version = "1.48"
[features]
parallel = ["cc/parallel"]
+# incomplete features that are not covered by a compatibility guarantee:
+experimental-async-fn = []
[dependencies]
cc = "1.0.49"
-codespan-reporting = "0.11"
-lazy_static = "1.4"
-proc-macro2 = { version = "1.0.26", default-features = false, features = ["span-locations"] }
+codespan-reporting = "0.11.1"
+once_cell = "1.9"
+proc-macro2 = { version = "1.0.39", default-features = false, features = ["span-locations"] }
quote = { version = "1.0", default-features = false }
scratch = "1.0"
-syn = { version = "1.0.70", default-features = false, features = ["parsing", "printing", "clone-impls", "full"] }
+syn = { version = "1.0.95", default-features = false, features = ["parsing", "printing", "clone-impls", "full"] }
[dev-dependencies]
+cxx = { version = "1.0", path = "../.." }
cxx-gen = { version = "0.7", path = "../lib" }
pkg-config = "0.3"
+[lib]
+doc-scrape-examples = false
+
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]