aboutsummaryrefslogtreecommitdiff
path: root/macro/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'macro/Cargo.toml')
-rw-r--r--macro/Cargo.toml14
1 files changed, 12 insertions, 2 deletions
diff --git a/macro/Cargo.toml b/macro/Cargo.toml
index a3df1018..65f15c3a 100644
--- a/macro/Cargo.toml
+++ b/macro/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "cxxbridge-macro"
-version = "1.0.42"
+version = "1.0.54"
authors = ["David Tolnay <dtolnay@gmail.com>"]
edition = "2018"
license = "MIT OR Apache-2.0"
@@ -14,10 +14,20 @@ categories = ["development-tools::ffi"]
[lib]
proc-macro = true
+[features]
+experimental = ["clang-ast", "flate2", "memmap", "serde", "serde_json"]
+
[dependencies]
proc-macro2 = "1.0"
quote = "1.0.4"
-syn = { version = "1.0.68", features = ["full"] }
+syn = { version = "1.0.70", features = ["full"] }
+
+# optional dependencies
+clang-ast = { version = "0.1", optional = true }
+flate2 = { version = "1.0", optional = true }
+memmap = { version = "0.7", optional = true }
+serde = { version = "1.0", optional = true, features = ["derive"] }
+serde_json = { version = "1.0", optional = true }
[dev-dependencies]
cxx = { version = "1.0", path = ".." }