aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbjacob <benoitjacob@google.com>2021-01-19 22:21:49 -0500
committerGitHub <noreply@github.com>2021-01-19 22:21:49 -0500
commit4ed621615d2f0a54410976cdaaae22779eaec664 (patch)
treed508bf20de9c68f19aea55330c4d94949c6b608e /CMakeLists.txt
parentb87d6d2e65ca24ba38e9afbf1e9d0744dbda82d3 (diff)
downloadruy-4ed621615d2f0a54410976cdaaae22779eaec664.tar.gz
Revert "Add CMake support with a converter from Bazel (#233)" (#243)
This reverts commit b87d6d2e65ca24ba38e9afbf1e9d0744dbda82d3.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
deleted file mode 100644
index 6577dd8..0000000
--- a/CMakeLists.txt
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2021 Google LLC
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# https://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-cmake_policy(SET CMP0012 NEW)
-cmake_policy(SET CMP0048 NEW)
-project(ruy CXX)
-cmake_minimum_required(VERSION 3.13) # Copied from IREE
-set(CMAKE_CXX_STANDARD 14)
-
-option(RUY_ENABLE_TESTS "Enable ruy's tests" ON)
-if (RUY_ENABLE_TESTS)
- enable_testing()
-endif()
-
-option(RUY_PROFILER "Enable ruy's built-in profiler (harms performance)" OFF)
-
-include(cmake/ruy_add_all_subdirs.cmake)
-include(cmake/ruy_cc_library.cmake)
-include(cmake/ruy_cc_binary.cmake)
-include(cmake/ruy_cc_test.cmake)
-
-# Disabling cpuinfo's tests and benchmarks to prevent a copy of its
-# googletest dependency getting downloaded into a 'deps' directory in the
-# source tree!
-set(CPUINFO_BUILD_BENCHMARKS OFF CACHE BOOL "" FORCE)
-set(CPUINFO_BUILD_UNIT_TESTS OFF CACHE BOOL "" FORCE)
-set(CPUINFO_BUILD_MOCK_TESTS OFF CACHE BOOL "" FORCE)
-add_subdirectory("third_party/cpuinfo" EXCLUDE_FROM_ALL)
-add_subdirectory("third_party/googletest" EXCLUDE_FROM_ALL)
-
-ruy_add_all_subdirs()