aboutsummaryrefslogtreecommitdiff
path: root/examples/cpp-interface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/cpp-interface/CMakeLists.txt')
-rw-r--r--examples/cpp-interface/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/examples/cpp-interface/CMakeLists.txt b/examples/cpp-interface/CMakeLists.txt
index 4e98dede..14f99376 100644
--- a/examples/cpp-interface/CMakeLists.txt
+++ b/examples/cpp-interface/CMakeLists.txt
@@ -12,6 +12,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-add_executable(spirv-tools-cpp-example main.cpp)
-spvtools_default_compile_options(spirv-tools-cpp-example)
-target_link_libraries(spirv-tools-cpp-example PRIVATE SPIRV-Tools-opt)
+if (NOT ${SPIRV_SKIP_EXECUTABLES})
+ add_executable(spirv-tools-cpp-example main.cpp)
+ spvtools_default_compile_options(spirv-tools-cpp-example)
+ target_link_libraries(spirv-tools-cpp-example PRIVATE SPIRV-Tools-opt)
+endif()