aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 926dadef..8ebcd93b 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -169,6 +169,17 @@ add_spvtools_unittest(
SRCS bit_stream.cpp
LIBS ${SPIRV_TOOLS})
+add_spvtools_unittest(
+ TARGET huffman_codec
+ SRCS huffman_codec.cpp
+ LIBS ${SPIRV_TOOLS})
+
+add_spvtools_unittest(
+ TARGET move_to_front
+ SRCS move_to_front_test.cpp
+ LIBS ${SPIRV_TOOLS})
+
+add_subdirectory(comp)
add_subdirectory(opt)
-add_subdirectory(val)
add_subdirectory(stats)
+add_subdirectory(val)