aboutsummaryrefslogtreecommitdiff
path: root/test/opt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/opt/CMakeLists.txt')
-rw-r--r--test/opt/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/opt/CMakeLists.txt b/test/opt/CMakeLists.txt
index bc44e8d6..6dfb1b75 100644
--- a/test/opt/CMakeLists.txt
+++ b/test/opt/CMakeLists.txt
@@ -42,6 +42,7 @@ add_spvtools_unittest(TARGET opt
desc_sroa_test.cpp
eliminate_dead_const_test.cpp
eliminate_dead_functions_test.cpp
+ eliminate_dead_input_components_test.cpp
eliminate_dead_member_test.cpp
feature_manager_test.cpp
fix_storage_class_test.cpp
@@ -82,6 +83,7 @@ add_spvtools_unittest(TARGET opt
propagator_test.cpp
reduce_load_size_test.cpp
redundancy_elimination_test.cpp
+ remove_dontinline_test.cpp
remove_unused_interface_variables_test.cpp
register_liveness.cpp
relax_float_ops_test.cpp
@@ -91,9 +93,10 @@ add_spvtools_unittest(TARGET opt
scalar_replacement_test.cpp
set_spec_const_default_value_test.cpp
simplification_test.cpp
+ spread_volatile_semantics_test.cpp
strength_reduction_test.cpp
strip_debug_info_test.cpp
- strip_reflect_info_test.cpp
+ strip_nonsemantic_info_test.cpp
struct_cfg_analysis_test.cpp
type_manager_test.cpp
types_test.cpp