aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100755
index 0000000..f7d47b5
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,35 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(src/stress.c)
+AM_INIT_AUTOMAKE(stress, 1.0.4)
+
+dnl Checks for programs.
+AC_PROG_CC
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(unistd.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+
+dnl Checks for library functions.
+AC_CHECK_LIB(m,sqrt)
+AC_CHECK_LIB(gen,basename)
+
+dnl Options that alter compile and link.
+AC_ARG_ENABLE([static],
+ AC_HELP_STRING([--enable-static],
+ [build static library @<:@default=no@:>@]),
+ [static=$enableval],
+ [static=no])
+
+if test "$static" = yes; then
+ # if we're using gcc, add `-static' to LDFLAGS
+ if test -n "$GCC" || test "$ac_cv_prog_gcc" = "yes"; then
+ STATIC_LD="-static"
+ LDFLAGS="$LDFLAGS -static"
+ fi
+fi
+
+AC_OUTPUT(Makefile src/Makefile doc/Makefile test/Makefile)