aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDave Beazley <dave-swig@dabeaz.com>2003-02-14 18:04:21 +0000
committerDave Beazley <dave-swig@dabeaz.com>2003-02-14 18:04:21 +0000
commit08c3b43b2405ec78bdbf28c63e4032ea35dac7da (patch)
treed58de2880624d5715fe7664360412bf5ac04b262 /configure.in
parent567394c2a8cc4697a30c66e39b0285d83fe3d0e4 (diff)
downloadswig-08c3b43b2405ec78bdbf28c63e4032ea35dac7da.tar.gz
Added John's perl5 patches
git-svn-id: https://swig.svn.sourceforge.net/svnroot/swig/trunk/SWIG@4310 626c5289-ae23-0410-ae9c-e8d60b6d4f22
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e9556cf5c..d3228b245 100644
--- a/configure.in
+++ b/configure.in
@@ -588,6 +588,13 @@ if test -n "$PERL"; then
else
AC_MSG_RESULT($PERL5LIB)
fi
+ AC_MSG_CHECKING(for Perl5 compiler options)
+ PERL5CCFLAGS=`($PERL -e 'use Config; print $Config{ccflags}') 2>/dev/null`
+ if test "$PERL5CCFLAGS" = "" ; then
+ AC_MSG_RESULT(not found)
+ else
+ AC_MSG_RESULT($PERL5CCFLAGS)
+ fi
else
AC_MSG_RESULT(unable to determine perl5 configuration)
PERL5EXT=$PERL5DIR
@@ -606,6 +613,7 @@ esac
AC_SUBST(PERL5EXT)
AC_SUBST(PERL5DYNAMICLINKING)
AC_SUBST(PERL5LIB)
+AC_SUBST(PERL5CCFLAGS)
# kludges to ease naming conventions conformance.
( cd Examples ;