aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2003-04-28 22:36:44 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2003-04-28 22:36:44 +0000
commit3b740345b2a3cea1ea16829ca2bed5a1dd833404 (patch)
treed9da56520c3a5895ea0264d3fda7c3701cb9ac5f /configure.in
parentf929918ea61f4d8933ceeb49839a1d2ae90c57a3 (diff)
downloadswig-3b740345b2a3cea1ea16829ca2bed5a1dd833404.tar.gz
Libtool added.
Removed last remaining subdirectory configure script (Tools directory) Decision to skip a language has moved from the top level makefile into this configure.in git-svn-id: https://swig.svn.sourceforge.net/svnroot/swig/trunk/SWIG@4724 626c5289-ae23-0410-ae9c-e8d60b6d4f22
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in111
1 files changed, 108 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b14277427..be6aafd38 100644
--- a/configure.in
+++ b/configure.in
@@ -31,12 +31,13 @@ dnl Checks for programs.
AC_PROG_CC
AC_PROG_CXX
AC_PROG_YACC
-AC_PROG_RANLIB
AC_EXEEXT
AC_OBJEXT
AM_PROG_CC_C_O # Needed for subdir-objects in AUTOMAKE_OPTIONS
AC_CHECK_PROGS(AR, ar aal, ar)
AC_SUBST(AR)
+AC_LIBTOOL_WIN32_DLL
+AC_PROG_LIBTOOL
AC_DEFINE_UNQUOTED(SWIG_CXX, ["$CXX"], [Compiler that built SWIG])
@@ -1198,6 +1199,105 @@ AC_SUBST(CSHARPDYNAMICLINKING)
AC_SUBST(CSHARPLIBRARYPREFIX) # Is this going to be used?
#----------------------------------------------------------------
+# Determine which languages to use for examples/test-suite and runtime lib
+#----------------------------------------------------------------
+
+SKIP_TCL=
+if test -z "$TCLINCLUDE" || test -z "$TCLLIB" ; then
+ SKIP_TCL="1"
+fi
+AM_CONDITIONAL(SKIP_TCL, test -n "$SKIP_TCL")
+AC_SUBST(SKIP_TCL)
+
+
+SKIP_PERL5=
+if test -z "$PERL" || test -z "$PERL5EXT" ; then
+ SKIP_PERL5="1"
+fi
+AM_CONDITIONAL(SKIP_PERL5, test -n "$SKIP_PERL5")
+AC_SUBST(SKIP_PERL5)
+
+
+SKIP_PYTHON=
+if test -z "$PYINCLUDE" || test -z "$PYLIB" ; then
+ SKIP_PYTHON="1"
+fi
+AM_CONDITIONAL(SKIP_PYTHON, test -n "$SKIP_PYTHON")
+AC_SUBST(SKIP_PYTHON)
+
+
+SKIP_JAVA=
+if test -z "$JAVA" || test -z "$JAVAC" || test -z "$JAVAINC" ; then
+ SKIP_JAVA="1"
+fi
+AM_CONDITIONAL(SKIP_JAVA, test -n "$SKIP_JAVA")
+AC_SUBST(SKIP_JAVA)
+
+
+SKIP_GUILE=
+if test -z "$GUILEINCLUDE" || test -z "$GUILELIB" ; then
+ SKIP_GUILE="1"
+fi
+AM_CONDITIONAL(SKIP_GUILE, test -n "$SKIP_GUILE")
+AC_SUBST(SKIP_GUILE)
+
+
+SKIP_MZSCHEME=
+if test -z "$MZC" ; then
+ SKIP_MZSCHEME="1"
+fi
+AM_CONDITIONAL(SKIP_MZSCHEME, test -n "$SKIP_MZSCHEME")
+AC_SUBST(SKIP_MZSCHEME)
+
+
+SKIP_RUBY=
+if test -z "$RUBY" || test -z "$RUBYINCLUDE" || test -z "$RUBYLIB" ; then
+ SKIP_RUBY="1"
+fi
+AM_CONDITIONAL(SKIP_RUBY, test -n "$SKIP_RUBY")
+AC_SUBST(SKIP_RUBY)
+
+
+SKIP_PHP4=
+if test -z "$PHP4" || test -z "$PHP4INC" ; then
+ SKIP_PHP4="1"
+fi
+AM_CONDITIONAL(SKIP_PHP4, test -n "$SKIP_PHP4")
+AC_SUBST(SKIP_PHP4)
+
+
+SKIP_OCAML=
+if test -z "$OCAMLBIN" || test -z "$OCAMLINC" ; then
+ SKIP_OCAML="1"
+fi
+AM_CONDITIONAL(SKIP_OCAML, test -n "$SKIP_OCAML")
+AC_SUBST(SKIP_OCAML)
+
+
+SKIP_PIKE="1" # Always skipped!
+if test -z "$PIKE" || test -z "$PIKEINCLUDE" ; then
+ SKIP_PIKE="1"
+fi
+AM_CONDITIONAL(SKIP_PIKE, test -n "$SKIP_PIKE")
+AC_SUBST(SKIP_PIKE)
+
+
+SKIP_CHICKEN=
+if test -z "$CHICKEN" || test -z "$CHICKENHOME" || test -z "$CHICKENLIB" ; then
+ SKIP_CHICKEN="1"
+fi
+AM_CONDITIONAL(SKIP_CHICKEN, test -n "$SKIP_CHICKEN")
+AC_SUBST(SKIP_CHICKEN)
+
+
+SKIP_CSHARP=
+if test -z "$CSHARPCILINTERPRETER" || test -z "$CSHARPCOMPILER" ; then
+ SKIP_CSHARP="1"
+fi
+AM_CONDITIONAL(SKIP_CSHARP, test -n "$SKIP_CSHARP")
+AC_SUBST(SKIP_CSHARP)
+
+#----------------------------------------------------------------
# Miscellaneous
#----------------------------------------------------------------
@@ -1231,15 +1331,20 @@ AC_ARG_WITH(release-suffix,
[release_suffix="$withval"], [release_suffix=""])
AC_SUBST(release_suffix)
-AC_CONFIG_SUBDIRS(Tools)
+release_suffix_libtool=
+if test -n "$release_suffix"; then
+ release_suffix_libtool="-release `echo $release_suffix | sed s/^-//`"
+fi
+AC_SUBST(release_suffix_libtool)
+
AC_CONFIG_FILES([ \
Makefile \
Source/Makefile \
- Runtime/Makefile \
Examples/Makefile \
Examples/guile/Makefile \
Examples/GIFPlot/Makefile \
Examples/GIFPlot/Lib/Makefile \
+ Runtime/Makefile \
])
AC_OUTPUT