aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2006-11-15 23:16:34 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2006-11-15 23:16:34 +0000
commit5dce7edb191767aa0b8cf8f30867a82042838688 (patch)
tree23bbcbadc2d8780d4dc8a9157fcd278a225c5218 /configure.in
parentc2a2108738f2ed84e5506e8ed655589346c29320 (diff)
downloadswig-5dce7edb191767aa0b8cf8f30867a82042838688.tar.gz
revert to previous formatting of file. Luigi, please add just the necessary mods back in
git-svn-id: https://swig.svn.sourceforge.net/svnroot/swig/trunk/SWIG@9562 626c5289-ae23-0410-ae9c-e8d60b6d4f22
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in128
1 files changed, 64 insertions, 64 deletions
diff --git a/configure.in b/configure.in
index d281f9a60..806dea407 100644
--- a/configure.in
+++ b/configure.in
@@ -1,8 +1,8 @@
dnl Process this file with autoconf to produce a configure script.
-dnl The macros which aren't shipped with the autotools are stored in the
+dnl The macros which aren't shipped with the autotools are stored in the
dnl Tools/config directory in .m4 files.
-AC_INIT([swig],[1.3.31],[http://www.swig.org])
+AC_INIT([swig],[1.3.30],[http://www.swig.org])
AC_PREREQ(2.58)
AC_CONFIG_SRCDIR([Source/Swig/swig.h])
AC_CONFIG_AUX_DIR([Tools/config])
@@ -291,25 +291,25 @@ echo ""
#----------------------------------------------------------------
AC_ARG_WITH(popen, AS_HELP_STRING([--without-popen], [Disable popen]), with_popen="$withval")
-if test x"${with_popen}" = xno ; then
+if test x"${with_popen}" = xno ; then
AC_MSG_NOTICE([Disabling popen])
else
AC_CHECK_FUNC(popen, AC_DEFINE(HAVE_POPEN, 1, [Define if popen is available]), AC_MSG_NOTICE([Disabling popen]))
fi
#----------------------------------------------------------------
-# Look for RxSpencer
+# Look for RxSpencer
#----------------------------------------------------------------
AC_ARG_WITH(rxspencer, AS_HELP_STRING([--with-rxspencer], [Enable RxSpencer]), with_rxspencer="yes")
-if test x"${with_rxspencer}" = xyes ; then
+if test x"${with_rxspencer}" = xyes ; then
#check first for the header
AC_CHECK_HEADER(rxspencer/regex.h,with_rxspencer="yes",with_rxspencer="no")
- if test x"${with_rxspencer}" = xyes ; then
+ if test x"${with_rxspencer}" = xyes ; then
# now check for the library
AC_CHECK_LIB(rxspencer, regcomp,with_rxspencer="yes",with_rxspencer="no")
fi
- if test x"${with_rxspencer}" = xyes ; then
+ if test x"${with_rxspencer}" = xyes ; then
# library and header are available
AC_DEFINE(HAVE_RXSPENCER, 1,[Define if rxspencer is available])
LIBS="$LIBS -lrxspencer"
@@ -455,7 +455,7 @@ AC_ARG_WITH(tcllib,[ --with-tcllib=path Set location of Tcl library direct
TCLLIB="-L$withval"], [TCLLIB=])
# First, check for "--without-tcl" or "--with-tcl=no".
-if test x"${TCLPACKAGE}" = xno -o x"${with_alllang}" = xno; then
+if test x"${TCLPACKAGE}" = xno -o x"${with_alllang}" = xno; then
AC_MSG_NOTICE([Disabling Tcl])
else
AC_MSG_CHECKING([for Tcl configuration])
@@ -516,7 +516,7 @@ if test -z "$TCLINCLUDE"; then
done
fi
if test -z "$TCLINCLUDE"; then
- AC_MSG_RESULT(not found)
+ AC_MSG_RESULT(not found)
fi
else
AC_MSG_RESULT($TCLINCLUDE)
@@ -562,7 +562,7 @@ AC_ARG_WITH(python, AS_HELP_STRING([--without-python], [Disable Python])
AS_HELP_STRING([--with-python=path], [Set location of Python executable]),[ PYBIN="$withval"], [PYBIN=yes])
# First, check for "--without-python" or "--with-python=no".
-if test x"${PYBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${PYBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling Python])
else
# First figure out the name of the Python executable
@@ -598,10 +598,10 @@ if test -n "$PYTHON"; then
PYLIBDIR=`($PYTHON -c "import sys; print sys.lib") 2>/dev/null`
if test -z "$PYLIBDIR"; then
# older versions don't have sys.lib so the best we can do is assume lib
- PYLIBDIR="lib"
+ PYLIBDIR="lib"
fi
AC_MSG_RESULT($PYLIBDIR)
-
+
# Set the include directory
AC_MSG_CHECKING(for Python header files)
@@ -662,7 +662,7 @@ AC_ARG_WITH(perl5, AS_HELP_STRING([--without-perl5], [Disable Perl5])
AS_HELP_STRING([--with-perl5=path], [Set location of Perl5 executable]),[ PERLBIN="$withval"], [PERLBIN=yes])
# First, check for "--without-perl5" or "--with-perl5=no".
-if test x"${PERLBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${PERLBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling Perl5])
PERL=
else
@@ -704,18 +704,18 @@ if test -n "$PERL"; then
AC_MSG_RESULT($PERL5LIB)
fi
AC_MSG_CHECKING(for Perl5 compiler options)
- PERL5CCFLAGS=`($PERL -e 'use Config; print $Config{ccflags}, "\n"' | sed "s/-Wdeclaration-after-statement//" | sed "s/-I/$ISYSTEM/") 2>/dev/null`
- if test "$PERL5CCFLAGS" = "" ; then
- AC_MSG_RESULT(not found)
- else
- AC_MSG_RESULT($PERL5CCFLAGS)
- fi
+ PERL5CCFLAGS=`($PERL -e 'use Config; print $Config{ccflags}, "\n"' | sed "s/-Wdeclaration-after-statement//" | sed "s/-I/$ISYSTEM/") 2>/dev/null`
+ if test "$PERL5CCFLAGS" = "" ; then
+ AC_MSG_RESULT(not found)
+ else
+ AC_MSG_RESULT($PERL5CCFLAGS)
+ fi
else
AC_MSG_RESULT(unable to determine perl5 configuration)
PERL5EXT=$PERL5DIR
fi
else
- AC_MSG_RESULT(could not figure out how to run perl5)
+ AC_MSG_RESULT(could not figure out how to run perl5)
fi
# Cygwin (Windows) needs the library for dynamic linking
@@ -740,7 +740,7 @@ AS_HELP_STRING([--with-java=path], [Set location of java executable]),[JAVABIN="
AC_ARG_WITH(javac, [ --with-javac=path Set location of javac executable],[JAVACBIN="$withval"], [JAVACBIN=])
# First, check for "--without-java" or "--with-java=no".
-if test x"${JAVABIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${JAVABIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling Java])
JAVA=
else
@@ -806,7 +806,7 @@ case $host in
JAVADYNAMICLINKING=""
JAVACFLAGS=""
fi ;;
-*-*-darwin*)
+*-*-darwin*)
JAVADYNAMICLINKING="-dynamiclib -framework JavaVM"
JAVACFLAGS=""
;;
@@ -824,7 +824,7 @@ esac
# Java on Mac OS X tweaks
case $host in
-*-*-darwin*)
+*-*-darwin*)
JAVASO=".jnilib"
JAVALDSHARED='$(CC)'
JAVACXXSHARED='$(CXX)'
@@ -856,7 +856,7 @@ AS_HELP_STRING([--with-gcj=path], [Set location of gcj executable]),[GCJBIN="$wi
AC_ARG_WITH(gcjh, [ --with-gcjh=path Set location of gcjh executable],[GCJHBIN="$withval"], [GCJHBIN=])
# First, check for "--without-gcj" or "--with-gcj=no".
-if test x"${GCJBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${GCJBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling GCJ])
else
if test "x$GCJBIN" = xyes; then
@@ -898,7 +898,7 @@ AC_ARG_WITH(guilelib,[ --with-guilelib=path Set location of Guile library di
GUILELIB="$withval"])
# First, check for "--without-guile" or "--with-guile=no".
-if test x"${GUILE}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${GUILE}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling Guile])
else
@@ -917,21 +917,21 @@ fi
if test -z "$GUILE" -o "x$GUILE" = xyes; then
if test -n "$GUILEPACKAGE"; then
- GUILE="$GUILEPACKAGE/bin/guile"
+ GUILE="$GUILEPACKAGE/bin/guile"
else
- GUILE=
+ GUILE=
fi
fi
if test -z "$GUILEINCLUDE"; then
if test -n "$GUILEPACKAGE"; then
- GUILEINCLUDE="$GUILEPACKAGE/include"
+ GUILEINCLUDE="$GUILEPACKAGE/include"
fi
fi
if test -z "$GUILELIB"; then
if test -n "$GUILEPACKAGE"; then
- GUILELIB="$GUILEPACKAGE/lib"
+ GUILELIB="$GUILEPACKAGE/lib"
fi
fi
@@ -940,27 +940,27 @@ AC_MSG_CHECKING(for Guile header files)
dirs="$GUILEINCLUDE"
for i in $dirs ; do
- if test -r $i/guile/gh.h; then
- AC_MSG_RESULT($i)
- GUILEINCLUDE="$ISYSTEM$i"
- break
- fi
+ if test -r $i/guile/gh.h; then
+ AC_MSG_RESULT($i)
+ GUILEINCLUDE="$ISYSTEM$i"
+ break
+ fi
done
if test -z "$GUILEINCLUDE"; then
- AC_MSG_RESULT(not found)
+ AC_MSG_RESULT(not found)
fi
AC_MSG_CHECKING(for Guile library)
dirs="$GUILELIB"
for i in $dirs ; do
- if test -r $i/libguile.so; then
- AC_MSG_RESULT($i)
- GUILELIB="$i"
- break
- fi
+ if test -r $i/libguile.so; then
+ AC_MSG_RESULT($i)
+ GUILELIB="$i"
+ break
+ fi
done
if test -z "$GUILELIB"; then
- AC_MSG_RESULT(not found)
+ AC_MSG_RESULT(not found)
fi
if test -z "$GUILELINK"; then
@@ -1008,7 +1008,7 @@ AS_HELP_STRING([--with-mzscheme=path], [Set location of MzScheme executable]),[
AC_ARG_WITH(mzc, AS_HELP_STRING([--with-mzc=path], [Set location of MzScheme's mzc]), [ MZCBIN="$withval"], [MZCBIN=])
# First, check for "--without-mzscheme" or "--with-mzscheme=no".
-if test x"${MZSCHEMEBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${MZSCHEMEBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling MzScheme])
MZC=
else
@@ -1024,7 +1024,7 @@ if test -z "$MZCBIN"; then
fi
if test -n "$MZSCHEME"; then
-AC_MSG_CHECKING(for MzScheme dynext object)
+AC_MSG_CHECKING(for MzScheme dynext object)
MZDYNOBJ=`$MZSCHEME --mute-banner --version --eval '(begin (require (lib "link.ss" "dynext")) (with-handlers (((lambda args #t) (lambda args #f))) (for-each (lambda (x) (display x) (display " ")) ((current-make-standard-link-libraries)))) (with-handlers (((lambda args #t) (lambda args #f))) (for-each (lambda (x) (display x) (display " ")) (expand-for-link-variant (current-standard-link-libraries)))))'`
AC_MSG_RESULT($MZDYNOBJ)
fi
@@ -1041,7 +1041,7 @@ AC_ARG_WITH(ruby, AS_HELP_STRING([--without-ruby], [Disable Ruby])
AS_HELP_STRING([--with-ruby=path], [Set location of Ruby executable]),[ RUBYBIN="$withval"], [RUBYBIN=yes])
# First, check for "--without-ruby" or "--with-ruby=no".
-if test x"${RUBYBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${RUBYBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling Ruby])
RUBY=
else
@@ -1091,10 +1091,10 @@ if test -n "$RUBY"; then
else # 1.6.x
link = "-l" + c[["RUBY_INSTALL_NAME"]]
end
-
+
# Get the target Ruby was built for
target = c[["target"]]
-
+
if target == "i386-pc-mswin32"
# Need to change msvcrt-ruby*.lib to -lmsvcrt-ruby*
ext = File.extname(link)
@@ -1162,7 +1162,7 @@ AC_ARG_WITH(php4, AS_HELP_STRING([--without-php4], [Disable PHP4])
AS_HELP_STRING([--with-php4=path], [Set location of PHP4 executable]),[ PHP4BIN="$withval"], [PHP4BIN=yes])
# First, check for "--without-php4" or "--with-php4=no".
-if test x"${PHP4BIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${PHP4BIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling PHP4])
PHP4=
else
@@ -1210,7 +1210,7 @@ AC_ARG_WITH(ocamlfind,[ --with-ocamlfind=path Set location of ocamlfind],[OCA
AC_ARG_WITH(ocamlmktop,[ --with-ocamlmktop=path Set location of ocamlmktop executable],[ OCAMLMKTOP="$withval"], [OCAMLMKTOP=])
# First, check for "--without-ocaml" or "--with-ocaml=no".
-if test x"${OCAMLBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${OCAMLBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling OCaml])
OCAMLBIN=
else
@@ -1306,7 +1306,7 @@ AC_ARG_WITH(pike, AS_HELP_STRING([--without-pike], [Disable Pike])
AS_HELP_STRING([--with-pike=path], [Set location of Pike executable]),[PIKEBIN="$withval"], [PIKEBIN=yes])
# First, check for "--without-pike" or "--with-pike=no".
-if test x"${PIKEBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${PIKEBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling Pike])
PIKEBIN=
else
@@ -1320,8 +1320,8 @@ fi
# Check for pike-config
# Priority: configure option, guessed from $PIKE, search from list
-AC_ARG_WITH(pike-config, AS_HELP_STRING([--with-pike-config=path],
- [Set location of pike-config script]),
+AC_ARG_WITH(pike-config, AS_HELP_STRING([--with-pike-config=path],
+ [Set location of pike-config script]),
[PIKECONFIG="$withval"], [PIKECONFIG=""])
if test -z "$PIKECONFIG" -a -n "$PIKE"; then
@@ -1331,7 +1331,7 @@ fi
# Check for a --with-pikeincl option to configure
# Priority: configure option, info from $PIKECONFIG, guessed by pike script
-AC_ARG_WITH(pikeincl, AS_HELP_STRING([--with-pikeincl=path],
+AC_ARG_WITH(pikeincl, AS_HELP_STRING([--with-pikeincl=path],
[Set location of Pike include directory]),
[PIKEINCLUDE="-I$withval"], [PIKEINCLUDE=])
@@ -1373,7 +1373,7 @@ AC_ARG_WITH(chicken, AS_HELP_STRING([--without-chicken], [Disable CHICKEN])
AS_HELP_STRING([--with-chicken=path], [Set location of CHICKEN executable]),[ CHICKENBIN="$withval"], [CHICKENBIN=yes])
# First, check for "--without-chicken" or "--with-chicken=no".
-if test x"${CHICKENBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${CHICKENBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling CHICKEN])
else
@@ -1433,7 +1433,7 @@ if test -n "$CHICKEN_CSC" ; then
CHICKENSHAREDLIB="`$CHICKEN_CSC -shared -libs` $CHICKENSHAREDLIB"
fi
if test -z "$CHICKENSHAREDLIB"; then
- AC_MSG_RESULT(not found)
+ AC_MSG_RESULT(not found)
else
AC_MSG_RESULT($CHICKENSHAREDLIB)
fi
@@ -1445,7 +1445,7 @@ if test -n "$CHICKEN_CSC" ; then
CHICKENLIB="`$CHICKEN_CSC -libs` $CHICKENLIB"
fi
if test -z "$CHICKENLIB"; then
- AC_MSG_RESULT(not found)
+ AC_MSG_RESULT(not found)
else
AC_MSG_RESULT($CHICKENLIB)
fi
@@ -1469,7 +1469,7 @@ AC_ARG_WITH(cil-interpreter, [ --with-cil-interpreter=path Set location of
AC_ARG_WITH(csharp-compiler, [ --with-csharp-compiler=path Set location of CSharp compiler],[CSHARPCOMPILERBIN="$withval"], [CSHARPCOMPILERBIN=])
# First, check for "--without-csharp" or "--with-csharp=no".
-if test x"${with_csharp}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${with_csharp}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling CSharp])
CSHARPCOMPILER=
else
@@ -1518,7 +1518,7 @@ if test -z "$CSHARPBIN" ; then
else
echo "mcs is not a working Mono C# compiler"
fi
- else
+ else
if test "csc" = "$CSHARPCOMPILER"; then
CSHARPPATHSEPARATOR="\\\\"
CSHARPCYGPATH_W='cygpath -w'
@@ -1588,7 +1588,7 @@ AC_ARG_WITH(lualib,[ --with-lualib=path Set location of Lua library direct
LUALIB="-L$withval"], [LUALIB=])
# First, check for "--without-lua" or "--with-lua=no".
-if test x"${LUABIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${LUABIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling Lua])
else
@@ -1628,8 +1628,8 @@ if test "$LUABIN"; then
else
LUADYNAMICLOADLIB=`$LUABIN -e '_,_,c=package.loadlib("no_such_lib","") if c~="absent" then print "1" end'`
fi
-
- if test -z "$LUADYNAMICLOADLIB"; then
+
+ if test -z "$LUADYNAMICLOADLIB"; then
AC_MSG_RESULT(no)
else
AC_MSG_RESULT(yes)
@@ -1653,7 +1653,7 @@ if test -z "$LUAINCLUDE"; then
fi
fi
if test -z "$LUAINCLUDE"; then
- AC_MSG_RESULT(not found)
+ AC_MSG_RESULT(not found)
else
AC_MSG_RESULT($LUAINCLUDE)
fi
@@ -1703,7 +1703,7 @@ AC_ARG_WITH(allegrocl, AS_HELP_STRING([--without-allegrocl], [Disable Allegro CL
AS_HELP_STRING([--with-allegrocl=path], [Set location of Allegro CL executable (alisp)]),[ ALLEGROCLBIN="$withval"], [ALLEGROCLBIN=yes])
# First, check for "--without-allegrocl" or "--with-allegrocl=no".
-if test x"${ALLEGROCLBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${ALLEGROCLBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling Allegro CL])
ALLEGROCLBIN=
else
@@ -1726,7 +1726,7 @@ AC_ARG_WITH(clisp, AS_HELP_STRING([--without-clisp], [Disable CLISP])
AS_HELP_STRING([--with-clisp=path], [Set location of CLISP executable (clisp)]),[ CLISPBIN="$withval"], [CLISPBIN=yes])
# First, check for "--without-clisp" or "--with-clisp=no".
-if test x"${CLISPBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${CLISPBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling CLISP])
CLISPBIN=
else
@@ -1749,7 +1749,7 @@ AC_ARG_WITH(r, AS_HELP_STRING([--without-r], [Disable R])
AS_HELP_STRING([--with-r=path], [Set location of R executable (r)]),[ RBIN="$withval"], [RBIN=yes])
# First, check for "--without-r" or "--with-r=no".
-if test x"${RBIN}" = xno -o x"${with_alllang}" = xno ; then
+if test x"${RBIN}" = xno -o x"${with_alllang}" = xno ; then
AC_MSG_NOTICE([Disabling R])
RBIN=
else