aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2007-08-09 23:13:39 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2007-08-09 23:13:39 +0000
commit665917ebae5d12d9d806b9ebe10e33872ee1c93c (patch)
tree5f0d50248258ab187f01fe1ab6d49e8e69550066 /configure.in
parentaa32a6b0943f88ed50926870376f25123a71a0ee (diff)
downloadswig-665917ebae5d12d9d806b9ebe10e33872ee1c93c.tar.gz
Improve TCL detection (for Ubuntu Feisty) and use tclConfig.sh for header file location
git-svn-id: https://swig.svn.sourceforge.net/svnroot/swig/trunk@9886 626c5289-ae23-0410-ae9c-e8d60b6d4f22
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e44cd155b..2282a1d90 100644
--- a/configure.in
+++ b/configure.in
@@ -470,9 +470,11 @@ if test x"${with_tclconfig}" != x ; then
fi
# check in a few common install locations
if test x"${TCLCONFIG}" = x ; then
- for i in `ls -d /usr/lib 2>/dev/null` \
- `ls -d /usr/local/lib 2>/dev/null` ; do
- if test -f "$i/tclConfig.sh" ; then
+ for i in `ls -d /usr/lib/ 2>/dev/null` \
+ `ls -d -r /usr/lib/tcl*/ 2>/dev/null` \
+ `ls -d /usr/local/lib/ 2>/dev/null` \
+ `ls -d -r /usr/local/lib/tcl*/ 2>/dev/null` ; do
+ if test -f $i"tclConfig.sh" ; then
TCLCONFIG=`(cd $i; pwd)`
break
fi
@@ -484,7 +486,7 @@ else
AC_MSG_RESULT(found $TCLCONFIG/tclConfig.sh)
. $TCLCONFIG/tclConfig.sh
if test -z "$TCLINCLUDE"; then
- TCLINCLUDE=$ISYSTEM$TCL_PREFIX/include
+ TCLINCLUDE=`echo $TCL_INCLUDE_SPEC | sed "s/-I/$ISYSTEM/"`
fi
if test -z "$TCLLIB"; then
TCLLIB=$TCL_LIB_SPEC