aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOlly Betts <olly@survex.com>2007-11-28 19:57:57 +0000
committerOlly Betts <olly@survex.com>2007-11-28 19:57:57 +0000
commit84dc1cc4f6e89f59067552ab218491c26f4dab6d (patch)
tree86c5b97dc2c236ca57bb473cc71482c22def8132 /configure.in
parent8dabd96606541193008ed24d36057be41f32b7c6 (diff)
downloadswig-84dc1cc4f6e89f59067552ab218491c26f4dab6d.tar.gz
Adjust most external references to say "PHP" not "PHP4". However, it's still
"--with-php4" for now. Prefer php5 to php to php4 in autodetection. git-svn-id: https://swig.svn.sourceforge.net/svnroot/swig/trunk@10175 626c5289-ae23-0410-ae9c-e8d60b6d4f22
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 50f65d393..79cee88d0 100644
--- a/configure.in
+++ b/configure.in
@@ -1158,40 +1158,41 @@ AC_SUBST(RUBYCCDLFLAGS)
AC_SUBST(RUBYDYNAMICLINKING)
#-------------------------------------------------------------------------
-# Look for Php4
+# Look for PHP
#-------------------------------------------------------------------------
PHP4BIN=
-AC_ARG_WITH(php4, AS_HELP_STRING([--without-php4], [Disable PHP4])
-AS_HELP_STRING([--with-php4=path], [Set location of PHP4 executable]),[ PHP4BIN="$withval"], [PHP4BIN=yes])
+AC_ARG_WITH(php4, AS_HELP_STRING([--without-php4], [Disable PHP])
+AS_HELP_STRING([--with-php4=path], [Set location of PHP executable]),[ PHP4BIN="$withval"], [PHP4BIN=yes])
# First, check for "--without-php4" or "--with-php4=no".
if test x"${PHP4BIN}" = xno -o x"${with_alllang}" = xno ; then
- AC_MSG_NOTICE([Disabling PHP4])
+ AC_MSG_NOTICE([Disabling PHP])
PHP4=
else
if test "x$PHP4BIN" = xyes; then
- AC_CHECK_PROGS(PHP4, php php4)
+ AC_CHECK_PROGS(PHP4, php5 php php4)
else
PHP4="$PHP4BIN"
fi
-AC_MSG_CHECKING(for PHP4 header files)
-PHP4CONFIG="${PHP4}-config"
+AC_MSG_CHECKING(for PHP header files)
+dnl /usr/bin/php5 -> /usr/bin/php-config5
+PHP4CONFIG=`echo "$PHP4"|sed 's/\([[45]]\?\)$/-config\1/'`
PHP4INC="`$PHP4CONFIG --includes 2>/dev/null`"
if test "$PHP4INC"; then
AC_MSG_RESULT($PHP4INC)
else
- dirs="/usr/include/php /usr/local/include/php /usr/include/php4 /usr/local/include/php4 /usr/local/apache/php"
+ dirs="/usr/include/php /usr/local/include/php /usr/include/php5 /usr/local/include/php5 /usr/include/php4 /usr/local/include/php4 /usr/local/apache/php"
for i in $dirs; do
echo $i
if test -r $i/php_config.h -o -r $i/php_version.h; then
AC_MSG_RESULT($i)
PHP4EXT="$i"
PHP4INC="-I$PHP4EXT -I$PHP4EXT/Zend -I$PHP4EXT/main -I$PHP4EXT/TSRM"
- break;
+ break
fi
done
fi