aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2003-01-09 23:39:48 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2003-01-09 23:39:48 +0000
commit96dcd2a74abb73b473cbf219ef41f37a80a9baea (patch)
tree7f1c08085712dbd3e2cbea0e1fb7d958a13b163d /configure.in
parent4a50d7184467f6a8a0c3bc8dd72681daec63bbed (diff)
downloadswig-96dcd2a74abb73b473cbf219ef41f37a80a9baea.tar.gz
Fix for cygpath if cygpath is not installed on Cygwin/Mingw machine or does not support --mixed option
git-svn-id: https://swig.svn.sourceforge.net/svnroot/swig/trunk/SWIG@4232 626c5289-ae23-0410-ae9c-e8d60b6d4f22
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9a0eca975..740ce52ec 100644
--- a/configure.in
+++ b/configure.in
@@ -980,10 +980,14 @@ AC_SUBST(PIKEDYNAMICLINKING)
#----------------------------------------------------------------
# Root directory
-# Translate path for native Windows compilers on Cygwin for use with 'make check'
+# Translate path for native Windows compilers for use with 'make check'
ROOT_DIR=`pwd`
case $host in
-*-*-cygwin* | *-*-mingw*) ROOT_DIR=`cygpath --mixed $ROOT_DIR`;;
+*-*-cygwin* | *-*-mingw*)
+ if (cygpath --mixed $ROOT_DIR) >/dev/null 2>/dev/null; then
+ ROOT_DIR=`cygpath --mixed $ROOT_DIR`
+ fi
+ ;;
esac
AC_SUBST(ROOT_DIR)