aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2002-12-23 22:50:26 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2002-12-23 22:50:26 +0000
commita4c4e8e8b207a9d20ea8e6b8b75760d52920894a (patch)
tree1b44a82d8e9f48c54d8a57203fdedca0e2c7c89f /configure.in
parentb88a7bfa05e9d3a7ce85e006e4b6473855c6774c (diff)
downloadswig-a4c4e8e8b207a9d20ea8e6b8b75760d52920894a.tar.gz
Automake used to build SWIG executable
Automake 1.7.x requires autoconf version 2.54 minimum git-svn-id: https://swig.svn.sourceforge.net/svnroot/swig/trunk/SWIG@4220 626c5289-ae23-0410-ae9c-e8d60b6d4f22
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in44
1 files changed, 14 insertions, 30 deletions
diff --git a/configure.in b/configure.in
index 91c03d714..9a0eca975 100644
--- a/configure.in
+++ b/configure.in
@@ -1,10 +1,12 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT([swig],[1.3.18],[http://www.swig.org])
-AC_PREREQ(2.53)
+AC_PREREQ(2.54)
AC_CONFIG_SRCDIR([Source/Swig/swig.h])
AC_CONFIG_AUX_DIR([Tools/config])
AC_CONFIG_HEADERS([Source/Include/swigconfig.h])
+AC_CANONICAL_HOST
+AM_INIT_AUTOMAKE
dnl Some extra defines for the config file
AH_TOP([
@@ -24,25 +26,20 @@ AH_TOP([
#define SWIG_TCL_RUNTIME "-L" LIBDIR " -lswigtcl" RELEASE_SUFFIX
])
-AC_CANONICAL_HOST
-
dnl Checks for programs.
-
AC_PROG_CC
AC_PROG_CXX
+AC_PROG_YACC
AC_PROG_RANLIB
-
-AC_DEFINE_UNQUOTED(SWIG_CXX, ["$CXX"], [Compiler that built SWIG])
-
-AC_SUBST(AR)
+AM_PROG_CC_C_O # Needed for subdir-objects in AUTOMAKE_OPTIONS
AC_CHECK_PROGS(AR, ar aal, ar)
+AC_SUBST(AR)
-AC_PROG_YACC
-YFLAGS=-d
-AC_SUBST(YFLAGS)
+AC_DEFINE_UNQUOTED(SWIG_CXX, ["$CXX"], [Compiler that built SWIG])
dnl Checks for header files.
AC_HEADER_STDC
+
dnl Checks for library functions.
# Set info about shared libraries.
@@ -990,6 +987,7 @@ case $host in
esac
AC_SUBST(ROOT_DIR)
+AC_SUBST(ac_aux_dir)
# Configure SWIG_LIB path
@@ -1004,30 +1002,16 @@ AC_ARG_WITH(release-suffix,
[release_suffix="$withval"], [release_suffix=""])
AC_SUBST(release_suffix)
-
AC_CONFIG_SUBDIRS(Tools)
-
-# NOTE: The following ref to `Source' should NOT be prefixed w/ `$srcdir/'.
-# We can remove it if `Source' ever has a generated file but not before.
-test -d Source || mkdir Source
-
-dnl We use the following in `AC_CONFIG_FILES' and "make distclean".
-configure_substituted_files=`echo \
+AC_CONFIG_FILES([
+ Makefile \
+ Source/Makefile \
+ Runtime/Makefile \
Examples/Makefile \
Examples/guile/Makefile \
Examples/GIFPlot/Makefile \
Examples/GIFPlot/Lib/Makefile \
- Makefile \
- Runtime/Makefile \
- Source/CParse/Makefile \
- Source/DOH/Makefile \
- Source/Modules/Makefile \
- Source/Preprocessor/Makefile \
- Source/Swig/Makefile \
-`
-AC_SUBST(configure_substituted_files)
-
-AC_CONFIG_FILES([$configure_substituted_files])
+])
AC_OUTPUT
dnl configure.in ends here