aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2003-05-19 22:01:11 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2003-05-19 22:01:11 +0000
commitce0191a83b5040ee138b2ec5fe2dc7a21e211c47 (patch)
tree6ffa348da38aaa5fe955e2ac135ddcee86e50235 /configure.in
parent81f898e2b7f74497e05efba0667e6bae4aae324f (diff)
downloadswig-ce0191a83b5040ee138b2ec5fe2dc7a21e211c47.tar.gz
Maximise warnings (gcc only) when building runtime libraries and executable only (not examples or test-suite).
Also more OCAML runtime library removal I just spotted. git-svn-id: https://swig.svn.sourceforge.net/svnroot/swig/trunk/SWIG@4800 626c5289-ae23-0410-ae9c-e8d60b6d4f22
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 15ba9c924..00ea697c4 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
+dnl The macros which aren't shipped with the autotools are stored in the
+dnl Tools/config directory as .m4 files.
AC_INIT([swig],[1.3.20],[http://www.swig.org])
AC_PREREQ(2.54)
@@ -16,7 +18,6 @@ AH_BOTTOM([
/* Values returned by SWIG when invoked with the -ldflags option */
#define SWIG_GUILE_RUNTIME "-L" LIBDIR " -lswigguile" RELEASE_SUFFIX
#define SWIG_MZSCHEME_RUNTIME "-L" LIBDIR " -lswigmz" RELEASE_SUFFIX
-#define SWIG_OCAML_RUNTIME "-L" LIBDIR " -lswigocaml" RELEASE_SUFFIX
#define SWIG_PERL_RUNTIME "-L" LIBDIR " -lswigpl" RELEASE_SUFFIX
#define SWIG_PIKE_RUNTIME "-L" LIBDIR " -lswigpike" RELEASE_SUFFIX
#define SWIG_PHP_RUNTIME "-L" LIBDIR " -lswigphp4" RELEASE_SUFFIX
@@ -37,6 +38,7 @@ AC_CHECK_PROGS(AR, ar aal, ar)
AC_SUBST(AR)
AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
+AC_COMPILE_WARNINGS # Increase warning levels
AC_DEFINE_UNQUOTED(SWIG_CXX, ["$CXX"], [Compiler that built SWIG])
AC_DEFINE_UNQUOTED(SWIG_PLATFORM, ["$build"], [Platform that SWIG is built for])