aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 2 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index 543274359..a38e97d2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2370,11 +2370,6 @@ AS_HELP_STRING([--with-go=path], [Set location of Go compiler]),[GOBIN="$withval
if test x"${GOBIN}" = xno; then
AC_MSG_NOTICE([Disabling Go])
GO=
- GOC=
- GO1=false
- GO12=false
- GO13=false
- GO15=false
GOGCC=false
GCCGO=
GOOPT=
@@ -2390,30 +2385,15 @@ else
GOGCC=false
GCCGO=
- GO1=false
- GO12=false
- GO13=false
- GO15=false
GOOPT=
GCCGOOPT=
GOVERSIONOPTION=
if test -n "$GO" ; then
- GO1=true
- GOVERSIONOPTION=version
- go_version=$($GO $GOVERSIONOPTION | sed -e 's/go version //')
- case "$go_version" in
- go1 | go1.[[01234]] | go1.[[01234]].*)
- GOC=$(sh -c "$(go env) && echo \$GOCHAR")c
- ;;
- *)
- GOC=compile
- ;;
- esac
AC_MSG_CHECKING([whether go version is too old])
case $go_version in
- go1.1.* | go1.1 | go1.0 | go1.0.* | go1 )
- AC_MSG_RESULT([yes - minimum version is 1.2])
+ go1.[012345]*)
+ AC_MSG_RESULT([yes - minimum version is 1.6])
GO=
GOOPT="-intgosize 32"
;;
@@ -2429,20 +2409,6 @@ else
esac
;;
esac
- case $go_version in
- go1.0 | go1.0.* | go1 | go1.1 | go1.1.*)
- GOOPT="$GOOPT -use-shlib"
- ;;
- go1.2 | go1.2.*)
- GO12=true
- ;;
- go1.3 | go1.3.* | go1.4 | go1.4.*)
- GO13=true
- ;;
- *)
- GO15=true
- ;;
- esac
fi
AC_CHECK_PROGS(GCCGO, gccgo)