aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorflorian <florian@a5019735-40e9-0310-863c-91ae7b9d1cf9>2015-08-09 08:16:54 +0000
committerflorian <florian@a5019735-40e9-0310-863c-91ae7b9d1cf9>2015-08-09 08:16:54 +0000
commit42c2a5bc38d5127c2d401e254c97eb213d69f668 (patch)
treef5315097cc4bc8389a08652281c12fbad7cf10a3 /configure.ac
parentb26101c4d128f0bfed780434c4e4f8d67f8aeee4 (diff)
downloadvalgrind-42c2a5bc38d5127c2d401e254c97eb213d69f668.tar.gz
Fix build breakage introduced in r15510.
git-svn-id: svn://svn.valgrind.org/valgrind/trunk@15511 a5019735-40e9-0310-863c-91ae7b9d1cf9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1a6cfdb65..d5111f753 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1891,7 +1891,14 @@ AC_GCC_WARNING_SUBST([write-strings], [FLAG_W_WRITE_STRINGS])
AC_GCC_WARNING_SUBST([empty-body], [FLAG_W_EMPTY_BODY])
AC_GCC_WARNING_SUBST([format], [FLAG_W_FORMAT])
# Disabled for now until all platforms are clean
-# AC_GCC_WARNING_SUBST([format-signedness], [FLAG_W_FORMAT_SIGNEDNESS])
+format_checking_enabled=no
+#format_checking_enabled=yes
+if test "$format_checking_enabled" = "yes"; then
+ AC_GCC_WARNING_SUBST([format-signedness], [FLAG_W_FORMAT_SIGNEDNESS])
+else
+ dumy_assignment_to_avoid_syntax_errors=1
+ AC_SUBST([FLAG_W_FORMAT_SIGNEDNESS], [])
+fi
AC_GCC_WARNING_SUBST([cast-qual], [FLAG_W_CAST_QUAL])
AC_GCC_WARNING_SUBST([old-style-declaration], [FLAG_W_OLD_STYLE_DECLARATION])
AC_GCC_WARNING_SUBST([ignored-qualifiers], [FLAG_W_IGNORED_QUALIFIERS])