aboutsummaryrefslogtreecommitdiff
path: root/android/WALT/app/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'android/WALT/app/build.gradle')
-rw-r--r--android/WALT/app/build.gradle77
1 files changed, 41 insertions, 36 deletions
diff --git a/android/WALT/app/build.gradle b/android/WALT/app/build.gradle
index 531142e..d3fd5ae 100644
--- a/android/WALT/app/build.gradle
+++ b/android/WALT/app/build.gradle
@@ -1,49 +1,54 @@
-apply plugin: 'com.android.model.application'
-
-model {
- android {
- compileSdkVersion 25
- buildToolsVersion "25.0.2"
-
- defaultConfig {
- applicationId "org.chromium.latency.walt"
- minSdkVersion.apiLevel 17
- targetSdkVersion.apiLevel 23
- versionCode 8
- versionName "0.1.7"
- }
- ndk {
- moduleName "sync_clock_jni"
- CFlags.addAll "-I${project.rootDir}/app/src/main/jni".toString(), "-g", "-DUSE_LIBLOG", "-Werror"
- ldLibs.addAll "OpenSLES", "log"
- }
- buildTypes {
- release {
+apply plugin: 'com.android.application'
+
+
+android {
+ compileSdkVersion 29
+ buildToolsVersion '29.0.3'
+
+ defaultConfig {
+ applicationId "org.chromium.latency.walt"
+ minSdkVersion 21
+ targetSdkVersion 29
+ versionCode 9
+ versionName "0.1.9"
+ }
+
+ externalNativeBuild.ndkBuild {
+ path 'src/main/jni/Android.mk'
+ }
+
+ buildTypes {
+ release {
minifyEnabled false
- proguardFiles.add(file("proguard-rules.pro"))
- }
- debug {
- ndk {
- debuggable true
- }
+ }
+ debug {
+ ndk {
+ debuggable true
}
}
}
+
+ ndkVersion "21.0.6113669"
+
+ lintOptions {
+ abortOnError false
+ }
}
dependencies {
- compile 'com.android.support:appcompat-v7:25.1.0'
- compile 'com.android.support:design:25.1.0'
- compile 'com.android.support:preference-v7:25.1.0'
- compile 'com.android.support:preference-v14:25.1.0'
- compile 'com.github.PhilJay:MPAndroidChart:v3.0.1'
- testCompile 'junit:junit:4.12'
- testCompile 'org.mockito:mockito-core:1.10.19'
- testCompile ('org.powermock:powermock-api-mockito:1.6.2') {
+ implementation 'androidx.appcompat:appcompat:1.1.0'
+ implementation 'com.google.android.material:material:1.1.0'
+ implementation 'androidx.preference:preference:1.1.1'
+ implementation 'androidx.legacy:legacy-preference-v14:1.0.0'
+ implementation 'com.github.PhilJay:MPAndroidChart:v3.0.1'
+ implementation 'androidx.localbroadcastmanager:localbroadcastmanager:1.0.0'
+ testImplementation 'junit:junit:4.13'
+ testImplementation 'org.mockito:mockito-core:1.10.19'
+ testImplementation ('org.powermock:powermock-api-mockito:1.6.6') {
exclude module: 'hamcrest-core'
exclude module: 'objenesis'
}
- testCompile ('org.powermock:powermock-module-junit4:1.6.2') {
+ testImplementation ('org.powermock:powermock-module-junit4:1.6.6') {
exclude module: 'hamcrest-core'
exclude module: 'objenesis'
}