summaryrefslogtreecommitdiff
path: root/rs.spec
diff options
context:
space:
mode:
authorJason Sams <rjsams@android.com>2009-05-27 14:45:32 -0700
committerJason Sams <rjsams@android.com>2009-05-27 14:45:32 -0700
commit6678e9b2568ad041429a2477177133fe4932159f (patch)
treed6b6cceb368e22e703c05e985dd654f58031fa3c /rs.spec
parent9e1b63bd982c2775b24f16ffda68dd5b06fca60f (diff)
downloadrs-6678e9b2568ad041429a2477177133fe4932159f.tar.gz
Implement first pass bitmap to allocation support. The Java bindings can create a 2D allocation by passing in a Bitmap object.
Diffstat (limited to 'rs.spec')
-rw-r--r--rs.spec13
1 files changed, 12 insertions, 1 deletions
diff --git a/rs.spec b/rs.spec
index 6168bd75..65a4a826 100644
--- a/rs.spec
+++ b/rs.spec
@@ -83,12 +83,23 @@ AllocationCreateSized {
ret RsAllocation
}
-AllocationCreateFromBitmap {
+AllocationCreateFromFile {
param const char *file
param bool genMips
ret RsAllocation
}
+AllocationCreateFromBitmap {
+ param uint32_t width
+ param uint32_t height
+ param RsElementPredefined dstFmt
+ param RsElementPredefined srcFmt
+ param bool genMips
+ param const void * data
+ ret RsAllocation
+ }
+
+
AllocationUploadToTexture {
param RsAllocation alloc
param uint32_t baseMipLevel